Ask Your Question
1

Network Manager and internet not working after yum autoremove

asked 2015-06-15 17:14:04 -0600

jstock23 gravatar image

(Fedora 21)

I recently ran "sudo yum autoremove" to clean up any unneeded packages, but I think that may have caused problems. Maybe you're not supposed to run it woithout arguments?

No problems occurred immediately, but I do remember that my network status icon in Gnome was now a question mark. A few days later I restarted my comp and since then I can't connect to any network, wired or wifi, and there is no network status icon or option from the top right menu of Gnome. I think I may have deleted the package and yet it still ran anyways because it was in memory. Maybe that's why the icon was no longer correct?

I believe I may have deleted Network Manager because I can't find it. I have tried disabling it and enabling network.service, but that hasn't worked.

How might I go about diagnosing what the real problem is? Thanks!

edit retag flag offensive close merge delete

Comments

1

Does “rpm -q NetworkManager” say you have no such package installed?

BRPocock gravatar imageBRPocock ( 2015-06-15 17:58:50 -0600 )edit

No, it lists version 0.9.10 (etc).

jstock23 gravatar imagejstock23 ( 2015-06-16 11:53:38 -0600 )edit
1

Just in case it isn't a package-related issue, have you checked Settings → Network, perhaps the network adapter isn't listed, is disabled, or sommat?

BRPocock gravatar imageBRPocock ( 2015-06-16 15:52:46 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2015-06-15 23:49:13 -0600

geforce gravatar image

Try running this to get the LAN adapter name

 ifconfig

Look at the output

$ ifconfig
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.1  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::922b:34ff:fe98:bee7  prefixlen 64  scopeid 0x20<link>
        ether 90:2b:34:98:be:e7  txqueuelen 1000  (Ethernet)
        RX packets 77670  bytes 63551566 (60.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 64646  bytes 9453338 (9.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Then run (change adapter name to suit)

su    
ifup enp3s0

This should connect it, if it works run

su
yum groups install @gnome
edit flag offensive delete link more

Comments

Edit to last comment. Actuallythe output is:

"configuration for virbr0 not found"

jstock23 gravatar imagejstock23 ( 2015-06-16 12:11:37 -0600 )edit

Looks like my first comment didn't submit. I said that I saw 4 different results. One called virbr0 had an IP address but was not running. Two others were a Docker one and one called "lo". Another was virbr0-cir i think, no IP address.

jstock23 gravatar imagejstock23 ( 2015-06-16 15:23:03 -0600 )edit
1

The interface lo is better known as the "loopback adapter," which is why it has an IP address of 127.0.0.1, an address reserved for this function. There are times that it's convenient for programs to act as though they're going out to the Internet when they're really communicating with other programs on the same machine, and the loopback interface gives them an easy way to do this.

sideburns gravatar imagesideburns ( 2015-06-16 15:41:18 -0600 )edit
0

answered 2015-06-16 15:50:37 -0600

BRPocock gravatar image

You can also boot from a USB/CD Live system, if that will get you networking. (In case too many pieces of your system were lost to bring up your network.)

Once you reach the LiveCD/USB desktop, mount your system root directory — either via “Files,” on the left-hand sidebar, or via “Disks,” by locating your root partition and clicking the “Play” button.

If you need to connect to your network (eg: WiFi passwork), do so now.

Open Terminal, and enter sudo -s (+ Return). Then, dnf groups list. (If you're on an older system, use yum instead of dnf each time.) Depending on your Fedora release, you'll see one like Fedora Workstation or Gnome Desktop on the list.

In “Files,” find your system disk on the left side; you should see the top-level system folders like “boot,” “dev,” “etc,” et al on the mounted system disc. Hit Control+L to open the Location bar, and Control+C to Copy the location where it's mounted. (It probably starts with “/run/media…”)

Then, type dnf --installroot (ending with a Space), and then press Control+Shift+V to paste the location name in; then continue with (starting with another Space) groups install "Fedora Workstation", and finally Return. — Note: for older releases, replace "Fedora Workstation" with the desktop environment you'd like to use, from the list you got from dnf groups list, surrounded by " (quotation marks).

The whole, final, line might look like

dnf --installroot /run/media/users/1000/uuid-ugly-abra-cada-bra0 groups install "Fedora Workstation"

(Don't worry if it word-wraps around in Terminal, but don't hit Return until the end.)

Once dnf (or yum) finishes, you should be able to reboot (without the LiveCD) and have NetworkManager and friends back up and running.

An alternative to groups install "Fedora Workstation" (or the like) might be to just dnf --installroot /run/…/… install NetworkManager — but it's likely that other things are lost or broken, and that may not be enough to get you back operational.

edit flag offensive delete link more

Comments

Hey thanks!

I've tried what you said with yum, however it hasn't changed anything. I got:

"No packages in any requested group available to install or update"

So does that mean I actually have Network Manager already but it just won't load? I try to find it with the Gnome "search", but it doesn't show up and of course it's not available in the top right menu.

Should I maybe rebuild it somehow, or delete and reinstall?

Thanks again.

jstock23 gravatar imagejstock23 ( 2015-06-17 18:43:13 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-06-15 17:14:04 -0600

Seen: 2,798 times

Last updated: Jun 15 '15