Ask Your Question
0

Multiple package conflicts after fedup [closed]

asked 2015-06-08 13:25:20 -0500

Maarten gravatar image

Hi all,

I just did a fedup from Fedora 20 to 21. The upgrade worked and my system is functional, though I seem to have multiple package conflicts. For example, ibus and ibus-libs give the following yum error:

Error: Package: ibus-1.5.10-4.fc21.x86_64 (updates)
           Requires: ibus-libs(x86-64) = 1.5.10-4.fc21
           Installed: ibus-libs-1.5.10-5.fc20.x86_64 (@updates/20)
               ibus-libs(x86-64) = 1.5.10-5.fc20
           Available: ibus-libs-1.5.9-5.fc21.x86_64 (fedora)
               ibus-libs(x86-64) = 1.5.9-5.fc21
           Available: ibus-libs-1.5.10-4.fc21.x86_64 (updates)
               ibus-libs(x86-64) = 1.5.10-4.fc21

It seems that a fc20 version of a package is installed while there are dependencies for a fc21 version, but the upgrade did not replace the fc21 version for some reason.

For some packages I could remove them and reinstall them in order to fix the issue, but ibus-libs has a large number of dependencies (e.g., empathy, nautilus, gnome shell etc).

Does anyone now how I can get yum to use the fc21 version without reinstalling all these packages?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by davidva
close date 2015-06-08 17:29:50.207731

Comments

Duplicated question with same user: https://ask.fedoraproject.org/en/ques...

davidva gravatar imagedavidva ( 2015-06-08 17:30:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-06-08 15:16:05 -0500

baoboa gravatar image

did you try dnf distro-sync after fedup ?

look at Cleaning Up Post Upgrade

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-06-08 13:25:20 -0500

Seen: 133 times

Last updated: Jun 08 '15