Ask Your Question
1

No wifi after kernel upgrade

asked 2015-06-02 06:29:49 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I am running Fedora 22 on a DELL XPS 13 notebook (2015 edition, model 9343, bios A04). After I upgraded the kernel from

4.0.4-301.fc22.x86_64

to

4.0.4-303.fc22.x86_64

wifi no longer works. I reinstalled broadcom-wl and rebooted but still no wifi. Suggestions are welcome.

edit retag flag offensive close merge delete

9 Answers

Sort by » oldest newest most voted
3

answered 2015-06-02 07:54:21 -0600

baoboa gravatar image

updated 2015-06-02 10:57:10 -0600

is there a kernel module loaded ?

try lsmod | grep wl

did you see anything with dmesg or lspci ?

look at this link for how to check

if your kernel module is provided by rpmfusion as kmod package it happen sometimes that the kernel is publish before the associated modules.

then you have 2 options

1) reboot and select the previous kernel and wait for the new kernel module to be published.

2) install the akmod version and it should rebuild the module at boot-up.

edit flag offensive delete link more

Comments

Problem solved after installing akmod-wl. THANK YOU.

cribari gravatar imagecribari ( 2015-06-02 08:15:56 -0600 )edit
2

answered 2015-06-15 16:36:47 -0600

Thesee gravatar image

try this,

# akmods --force 
Checking kmods exist for 4.0.4-303.fc22.x86_64             [  OK  ] 
Building and installing wl-kmod

then

# modprobe wl

Regards

edit flag offensive delete link more

Comments

Thanks! It's work! :)

Jeremy gravatar imageJeremy ( 2015-08-06 08:15:58 -0600 )edit

when I do

# akmods --force

it only says

Checking kmods exists for 4.2.5-300.fc23.x86_64        [  OK  ]

:(

ViO gravatar imageViO ( 2015-11-18 08:46:46 -0600 )edit
0

answered 2015-06-02 08:14:10 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I did not find anything revealing with dmesg. I am attaching some info below. I noticed that I have kmod-wl-4.0.4-301 but not kmod-wl-4.0.4-303. Could that be causing the problem? I have already run sudo dnf update but that package was not update to version 303. Thank you.

[cribari@darwin4 ~] $ uname -a 
Linux darwin4 4.0.4-303.fc22.x86_64 #1 SMP Thu May 28 12:37:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[cribari@darwin4 ~] $ lsmod | grep wl
[cribari@darwin4 ~] $ iwconfig
lo        no wireless extensions.

[cribari@darwin4 ~] $ lspci 00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09) 00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) 00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09) 00:04.0 Signal processing controller: Intel Corporation Broadwell-U Camarillo Device (rev 09) 00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03) 00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03) 00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03) 00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3) 00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3) 00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03) 00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03) 00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03) 00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03) 00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03) 01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5249 PCI Express Card Reader (rev 01) 02:00.0 Network controller: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter (rev 03)

lspci -vnn | grep -i net 02:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)

[cribari@darwin4 ~] $ dnf list installed | grep wl Failed to synchronize cache for repo 'livna' from 'http://rpm.livna.org/mirrorlist': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for http://rpm.livna.org/mirrorlist [Could not resolve host: rpm.livna.org], disabling. broadcom-wl.noarch 6.30.223.248-2.fc22 @System iwl100-firmware.noarch 39.31.5.1-52.fc22 @System iwl1000-firmware.noarch 1:39.31.5.1-52.fc22 @System iwl105-firmware.noarch 18.168.6.1-52.fc22 @System iwl135-firmware.noarch 18.168.6.1-52.fc22 @System iwl2000-firmware.noarch 18.168.6.1-52.fc22 @System iwl2030-firmware.noarch 18.168.6.1-52.fc22 @System iwl3160-firmware.noarch 1:25.17.12.0-52.fc22 @System iwl3945-firmware.noarch 15.32.2.9-52.fc22 @System iwl4965-firmware.noarch 228.61.2.24-52.fc22 @System iwl5000-firmware.noarch 8.83.5.1_1-52.fc22 @System iwl5150-firmware.noarch 8.24.2.2-52.fc22 @System iwl6000-firmware.noarch 9.221.4.1-52.fc22 @System iwl6000g2a-firmware.noarch 18.168.6.1-52 ...

(more)
edit flag offensive delete link more
0

answered 2015-06-03 04:24:36 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Try this:

# wget http://downloads.openwrt.org/sources/broadcom-wl-5.100.138.tar.bz2

# tar jxvf broadcom-wl-5.100.138.tar.bz2

# cd broadcom-wl-5.100.138/linux

# b43-fwcutter -w /lib/firmware wl_apsta.o

# modprobe -r b43

# modprobe b43

g.

edit flag offensive delete link more

Comments

Works like a charm, much easier than the other suggestions.

Benjamin Sølberg gravatar imageBenjamin Sølberg ( 2015-10-06 18:08:16 -0600 )edit

It`s best solution? Thanks!

Goremchik gravatar imageGoremchik ( 2015-12-05 11:44:59 -0600 )edit

Works.(ACER aspire E5 with wifi Broadcom Corporation BCM43142 802.11b/g/n (rev 01))

halaszsandor gravatar imagehalaszsandor ( 2016-02-01 14:11:33 -0600 )edit
0

answered 2015-06-09 11:53:45 -0600

hamed gravatar image
edit flag offensive delete link more
0

answered 2015-06-02 08:46:03 -0600

sergiomb gravatar image
dnf list installed | grep kernel

have you installed kernel-modules ?

edit flag offensive delete link more

Comments

I have kernel-modules.x86_64 installed. See the output in my comment.

cribari gravatar imagecribari ( 2015-06-02 09:33:12 -0600 )edit
0

answered 2015-06-22 15:12:44 -0600

Bear in mind that if you may not be able to use uefi if you add the wl module. I had to turn off secure boot in the firmware of my new Lenovo Y50, that uses the 4352 wireless card (sadly). Wireless now works (good), bluetooth doesn't seem to (not so good) and it is a major PITA because one has to use rpmfusion nonfree to get it to work at all. Sigh.

edit flag offensive delete link more

Comments

I don't think UEFI and drivers are related. UEFI is a replacement for bios. Once you've booted into Fedora, you shouldn't have to worry about UEFI. My guess is your installation was slightly different between the BIOS and UEFI versions.

Utkarsh Sinha gravatar imageUtkarsh Sinha ( 2015-08-27 20:05:15 -0600 )edit

This solution was outdated even when it was posted. It applied to a very specific set of incompatible circumstances that shouldn’t occur in an updated system.

Aeyoun gravatar imageAeyoun ( 2015-12-25 15:26:07 -0600 )edit
0

answered 2015-12-05 07:00:14 -0600

I found that onpubcom's solution here worked perfectly: https://onpub.com/install-broadcom-li...

edit flag offensive delete link more
0

answered 2015-06-02 23:01:49 -0600

fdisk gravatar image

I thought I would comment here as I had the exact same issue with a Macbook Pro mid 2010 with Broadcom 4322.

The problem is the wl module is not loaded, and is not available in the repos. Note that this workaround is completely at your own risk, but worked for me.

Steps:

Create the folder for the module:

$ sudo mkdir -p /lib/modules/4.0.4-303.fc22.x86_64/extra/wl

Next, copy the old wl.ko to the new location

$ sudo cp /lib/modules/4.0.4-301.fc22.x86_64/extra/wl/wl.ko /lib/modules/4.0.4-303.fc22.x86_64/extra/wl

Finally, replace the version numbers in the new file with the correct version numbers:

$ sudo sed -i 's/-301/-303/g' /lib/modules/4.0.4-303.fc22.x86_64/extra/wl/wl.ko

Now, run depmod so your system willl find the module:

$ sudo depmod -a

Finally, run modprobe wl to get wifi again.

$ sudo modprobe wl

Hope that helps! Note this might break something. But it at least fixed my wifi.

edit flag offensive delete link more

Comments

Thanks, this also worked for my Fedora 22, Macbook Pro Late 2013. :D

Samuel Lee gravatar imageSamuel Lee ( 2015-06-04 04:30:36 -0600 )edit

Thanks a lot! It's work! :)

Vyacheslav gravatar imageVyacheslav ( 2015-06-14 09:53:01 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-06-02 06:29:49 -0600

Seen: 20,691 times

Last updated: Jun 15 '15