Ask Your Question
2

How to fix font rendering of Monaco?

asked 2015-05-31 07:50:09 -0600

chipf0rk gravatar image

I have severe problems with the rendering of the Monaco font family under Fedora 21. I've already followed the steps here to change the general font rendering to look more pleasing (in my taste), but for the Monaco font, I still get awful results (examples from Google Chrome, but also looks very similar in Firefox)

It only happens for a few font sizes, the worst being 14px:

Monaco at font-size:14px in Google Chrome; looks similar in Firefox

15px in comparison:

Monaco at font-size:15px

Changing the hinting/antialias rendering in gnome-tweak-tool doesn't change the appearance at all, not even after fc-cache -fv and a full restart of Chrome.

Is there any way to fix this?

edit retag flag offensive close merge delete

Comments

Can you please post examples, pictures from Firefox so we can focus there? . Google Chrome is known for its issues with Fonts Rendering and incompatibility with Desktop Themes in general.

NickTux gravatar imageNickTux ( 2015-05-31 09:57:45 -0600 )edit
1

As I said, it's extremely similar (also 14px): http://i.imgur.com/Z3qvmJZ.png

chipf0rk gravatar imagechipf0rk ( 2015-06-01 02:07:47 -0600 )edit

Yes, awful results indeed. Maybe is the Font ?(not sure). I have followed the same guide and I saw a major improvement in rendering. In .Xresources I only have Xft.lcdfilter: lcddefault though, also I don't use external fonts but the ones are shipped with Fedora.

NickTux gravatar imageNickTux ( 2015-06-01 08:35:21 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-06-01 08:45:23 -0600

NickTux gravatar image

updated 2015-06-01 09:49:11 -0600

Some scalable fonts have embedded bitmap versions which are rendered instead, mainly at smaller sizes. Force using scalable fonts at all sizes by Disabling embedded bitmap.

To disable embedded bitmap for all fonts:

~/.config/fontconfig/conf.d/20-no-embedded.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <match target="font">
    <edit name="embeddedbitmap" mode="assign">
      <bool>false</bool>
    </edit>
  </match>
</fontconfig>

To disable embedded bitmap fonts for a specific font:

<match target="font">
  <test qual="any" name="family">
    <string>Monaco</string>
  </test>
  <edit name="embeddedbitmap"><bool>false</bool></edit>
</match>

Source

Try above suggestions. I don't have any other ones.

If you cannot find ~/.config/fontconfig/conf.d/ you can try creating these folders with

mkdir -p ~/.config/fontconfig/conf.d/

or place above .conf file(s) inside /usr/share/fontconfig/ folder instead.

edit flag offensive delete link more

Comments

That did indeed fix it! I went with the second option. Thank you very much.

chipf0rk gravatar imagechipf0rk ( 2015-06-02 11:12:39 -0600 )edit

Thanks... the font now rendered smoothly ;) wondering why this not enabled by default

Biji gravatar imageBiji ( 2016-05-02 05:14:48 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-05-31 07:50:09 -0600

Seen: 1,827 times

Last updated: Jun 01 '15