Ask Your Question
1

Connection to network completely non-functional

asked 2015-05-30 11:54:55 -0600

SprightlyOaf gravatar image

updated 2015-05-31 09:00:20 -0600

Hello friends!

The problem at hand

I've just installed Fedora 22 (Workstation) from a Live CD onto a Macbook Pro (machine details below) and for the most part, it went smoothly - unfortunately, however, all throughout it doesn't appear as though Fedora recognizes the Mac's capacity to connect to the internet (whether I booted into the desktop environment or straight to the install process). Even tried reinstalling while connected via an ethernet cable - no luck. No network icon is present in the upper right hand corner and none of the networks (wired or not) appear in the Network section of the Settings application.

I'm quite positive the network itself is functioning fine (I'm using a different computer on the same wifi to type this) and that the hardware is perfectly fine as well - before I wiped the hard drive and installed Fedora over it, Mac OS X connected to the wifi without problems. (Yes, I know, I should have backed up the OS first. I'm new to this.)

Hopefully relevant information

  • Machine details

2009 Macbook Pro bought from a friend - generally in perfect working condition except for a bad battery

Processor: Intel Core 2 Duo CPU P8700 @ 2.53 GHz x2

GNOME 3.16.2

Graphics: Gallium 0.4 on NVAC

64-bit machine (Installed 64-bit version of Fedora)

Memory: 3.6 GiB

Disk: 242 GB

  • Results of bash commands which I don't understand, but which were scrounged from Googling the answers to similar problems so maybe they're useful?
[sprightlyoaf@herp-derp ~]$ cat /etc/resolv.conf

[sprightlyoaf@herp-derp ~]$ ip link
1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s10: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
    link/ether 64:b9:e8:cb:cd:04 brd ff:ff:ff:ff:ff:ff


[sprightlyoaf@herp-derp ~]$ ip addr

1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s10: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 64:b9:e8:cb:cd:04 brd ff:ff:ff:ff:ff:ff

[sprightlyoaf@herp-derp ~]$ ip route

[sprightlyoaf@herp-derp ~]$ NetworkManagermsgs

bash: NetworkManagermsgs: command not found...

[sprightlyoaf@herp-derp ~]$ Network Manager msgs

bash: Network: command not found...

[sprightlyoaf@herp-derp ~]$ ican'ttype

^C

[sprightlyoaf@herp-derp ~]$ NetworkManager msgs

You must be root to run NetworkManager!

[sprightlyoaf@herp-derp ~]$ sudo !!

sudo NetworkManager msgs
[sudo] password for sprightlyoaf:

[sprightlyoaf@herp-derp ~]$ sudo NetworkManager msgs

[sprightlyoaf@herp-derp ~]$ service NetworkManager start

Redirecting to /bin/systemctl start  NetworkManager.service

 [sprightlyoaf@herp-derp ~]$ systemctl | grep NetworkManager

  NetworkManager.service                                                                                                loaded active running   Network Manager

[sprightlyoaf@herp-derp ~]$ systemctl | grep Network

  NetworkManager.service                                                                                                loaded active running ...
(more)
edit retag flag offensive close merge delete

Comments

1

Welcome to ask.fedora and thank you for a properly detailed question. Alas, I don't use a Mac, so I don't know the answer. However, I'd like to point out (both for you and others) that the reason to use the Live CD is to make sure that everything is working before you install, so that you can work out any problems while your old, working system is still available. Oh well, live and learn. I know that there are a number of people here running Fedora on a Mac who can help you. Best of luck!

sideburns gravatar imagesideburns ( 2015-05-30 15:37:39 -0600 )edit

Yeah, I was reckless. Lesson learned though. Thanks!

SprightlyOaf gravatar imageSprightlyOaf ( 2015-05-30 19:02:34 -0600 )edit
1

Don't worry; tish happens. I mentioned it party in the hopes that some other newcomer will run across it before making the same mistake. Have you tried using a different Ethernet cable, or hooking that cable to a different machine?

sideburns gravatar imagesideburns ( 2015-05-30 21:05:03 -0600 )edit
1

post

lspci -nvk
geforce gravatar imagegeforce ( 2015-05-31 05:52:49 -0600 )edit

@sideburns Y'know, it's funny, I've read plenty of times about how it's important to back stuff up, not do anything permanent, etc. plenty of times, but when push came to shove I was always impatient enough to say, "Eh. I'll fix it later." Guess I had to learn this one the hard way. You're right, hopefully others will listen a bit better. :D

And I haven't, but I'll give it a go now. Should be able to find another cable around here...

SprightlyOaf gravatar imageSprightlyOaf ( 2015-05-31 08:21:04 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-05-31 07:13:28 -0600

geforce gravatar image

updated 2015-05-31 08:57:16 -0600

Both network adapters have kernel modules loaded

00:0a.0 0200: 10de:0ab0 (rev b1) Subsystem: 10de:cb79 Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 27 Memory at d3486000 (32-bit, non-prefetchable) [size=4K] I/O ports at 21e0 [size=8] Memory at d3489000 (32-bit, non-prefetchable) [size=256] Memory at d3489300 (32-bit, non-prefetchable) [size=16] Capabilities: [44] Power Management version 2 Capabilities: [50] MSI: Enable+ Count=1/16 Maskable+ 64bit+ Kernel driver in use: forcedeth Kernel modules: forcedeth

03:00.0 0280: 14e4:432b (rev 01) Subsystem: 106b:008d Flags: bus master, fast devsel, latency 0, IRQ 21 Memory at d3200000 (64-bit, non-prefetchable) [size=16K] Capabilities: [40] Power Management version 3 Capabilities: [58] Vendor Specific Information: Len=78 Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+ Capabilities: [d0] Express Endpoint, MSI 00 Capabilities: [100] Advanced Error Reporting Capabilities: [13c] Virtual Channel Capabilities: [160] Device Serial Number 91-7e-bb-ff-ff-1b-00-26 Capabilities: [16c] Power Budgeting Kernel driver in use: b43-pci-bridge Kernel modules: ssb

Can you post

ifconfig

and

iwconfig

Ok does this bring up the ethernet?

su
ifup enp0s10
edit flag offensive delete link more

Comments

Yup, they're in there. Just do a search for 'em. :D

I've tried formatting the bash logs a little better - hopefully they're more legible now.

SprightlyOaf gravatar imageSprightlyOaf ( 2015-05-31 08:04:21 -0600 )edit

Hm... although, those logs are from when I wasn't hooked up to an ethernet cable. I'll hook it up and see if the results differ. I'm assuming the hardware of the computer is picking up the wifi either way?

SprightlyOaf gravatar imageSprightlyOaf ( 2015-05-31 08:20:20 -0600 )edit

I think ifup worked! Either that or getting a properly functioning ethernet cable. Or both? Either way.

SprightlyOaf gravatar imageSprightlyOaf ( 2015-05-31 10:48:41 -0600 )edit
0

answered 2015-05-31 11:42:39 -0600

SprightlyOaf gravatar image

updated 2015-05-31 14:43:18 -0600

Victory! Found the necessary drivers by running lspci which came out saying the wireless card was from Broadcom. Used Google-fu, found this readme, which under the heading for "HOW TO INSTALL A PRE-COMPILED DRIVER" contained the addresses of two RPM Fusion releases. Downloaded 'em with Firefox, opened 'em with Software, did this: su - yum update yum install kmod-wl reboot

And badda bing, badda boom, wifi's working. Thank you both so much, I couldn't have done this without you.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-30 11:54:55 -0600

Seen: 520 times

Last updated: May 31 '15