Ask Your Question
6

Why do I get the "Oh no! Something has gone wrong" screen when using the Fedora 22 live DVD?

asked 2015-05-29 09:57:58 -0600

markito3 gravatar image

updated 2018-09-24 09:11:25 -0600

Trying to boot from a live DVD for Fedora 22, I get:

Oh no! Something has gone wrong. A problem has occurred and the system can't recover. All extensions have been disabled as a precaution.

See https://goo.gl/photos/AwGhyTEGpG9nGMUZ9 for the error screen.

At this point, the mouse pointer has disappeared, but hitting enter puts me back to the ascii screen. From there power down is the only option. See https://goo.gl/photos/1jFAqomb6uNLwBLP8 for the screen.

I know this is slightly inconsistent with what I said before, but at some point I managed to move the mouse blindly and click wildly and I got the system to install to the hard drive (the desired goal, no worries). The resulting system gave me the same error screen after authenticating my login.

I have downloaded the iso twice and the SHA sum checks out each time. I have burned the DVD twice and get the same behavior for both.

Are others experiencing this?

This is on a Dell E4300 Latitude laptop. I have since dropped back and re-installed Fedora 21 from its live DVD, without incident.

edit retag flag offensive close merge delete

Comments

1

looks like your graphic card is not compatible or the driver is broken ( nvidia ? )

baoboa gravatar imagebaoboa ( 2015-05-29 10:03:04 -0600 )edit
1

at boot up (grub->troubleshooting ) you have an option for a basic video mode

baoboa gravatar imagebaoboa ( 2015-05-29 10:04:29 -0600 )edit
1

I got stuck with the very same scenario yesterday and only managed to install F22 with the net install version. Sadly, I had to select Gnome with Wayland in the login screen afterwards, otherwise the X crashed as you reported it. So I respectfully suspect of a bug in Xorg, although I'm failing to find a relevant entry in Bugzilla. :( As it is now, F22 is unusable to me because Wayland runs poorly on my system. Update: I installed Cinnamon and it's working like a charm, maybe Gnome is the culprit here.

Paulo Cereda gravatar imagePaulo Cereda ( 2015-05-29 11:21:53 -0600 )edit

Just a quick note to OP. When it drops you into the "ascii screen" you can still use ctrl+alt+F1 to ctrl+alt+F6 and switch to a different console, where you can log in as a root user. That could be useful if someone comes up with a workaround or requests log files etc.

teodor gravatar imageteodor ( 2015-05-29 15:11:21 -0600 )edit

Same problem here on ThinkPad T500 with Intel's integrated graphics. Fedora Workstation 21 works like a charm but Fedora Workstation 22 is uninstallable at the moment.

teodor gravatar imageteodor ( 2015-05-29 23:59:08 -0600 )edit

12 Answers

Sort by ยป oldest newest most voted
5

answered 2015-06-11 12:20:33 -0600

teodor gravatar image

Hi, finally got it sorted for Live DVD - no need for netinst.

Boot as usual and just wait until the graphical installer starts and you see that "Oh no!" message. Then press ctrl+alt+f4 to switch to a virtual terminal, where you have to log in as a root user with no password. Once logged in you can uninstall libinput with this command:

dnf remove xorg-x11-drv-libinput

Now you have to clean up a little bit and log out:

killall -u liveuser
logout

At this point you are ready to start the installer. To do this log in as liveuser (again on that virtual terminal) and issue this command:

startx

That should take you to live dvd GNOME environment.

The only trouble is that you will hit exactly the same problem when you try to log in on a freshly installed system. So once again you will have to switch to a virtual terminal (ctrl+alt+f4), log in as your newly created user, remove libinput package (sudo dnf remove xorg-x11-drv-libinput), log in to a graphical environment (ctrl+alt+f1), start a terminal, issue this command:

gsettings set org.gnome.desktop.peripherals.touchpad scroll-method "edge-scrolling"

FINALLY you can reinstall libinput (sudo dnf install xorg-x11-drv-libinput) and enjoy Fedora 22!

Sounds like a lot of hassle but it's really not that bad and it worked for me. Let me know if you have any issues with this method.

edit flag offensive delete link more

Comments

It's solved same problem in my Dell Inspirou 1545. Thanks

Gilson Couto gravatar imageGilson Couto ( 2015-06-17 11:34:25 -0600 )edit

it's solved the problem but when i reinstall xorg-x11-drv-libinput the problem return :\, i remove it to use fedora 22

HooRaafat gravatar imageHooRaafat ( 2015-06-20 16:12:17 -0600 )edit

I have encountered the same issue with the live ISO of Fedora 22-3 Workstation 32bit (running off a usb stick). The fix worked! I added the information to THIS bug report in redhat bugzilla: https://bugzilla.redhat.com/show_bug.... i think it is the same issue posted there , but not entirely sure.

vlad gravatar imagevlad ( 2015-07-02 15:43:00 -0600 )edit

This worked for me, Dell T110 poweredge server. This is a pretty severe bug. I almost gave up on Fedora 22 completely. I hope this is in the errata.

Unfortunately, I don't have enough points to up-vote this answer yet. Hopefully others will upvote.

Bug report: BugID 1226553 https://bugzilla.redhat.com/show_bug....

rct gravatar imagerct ( 2015-07-09 11:43:29 -0600 )edit

Thank you! solved problem for me on a Dell XPS M1330.

poelstra gravatar imagepoelstra ( 2015-07-28 15:42:32 -0600 )edit
0

answered 2015-08-21 05:01:34 -0600

Sorry folks,

No answer from me.. but I have tried installing, from the 22 Live iso, on a number of Dell laptops and Desktops.... and its pretty much un-installable. Whilst I understand that the community is about solving problems; I think its back to the drawing board for 22

edit flag offensive delete link more
0

answered 2015-06-27 23:01:32 -0600

shadowhh32 gravatar image

Both of you: Cinnamon only highlights the problem.You have ZERO 3d acceleration. I get the same issue with fedora 21 workstation and have to use chapeau (or korora) to get anywhere.The 21 ISO is out of date and this is part of the problem.Wayland runs whether you disabled it or not.Lucky us. Wayland isnt the issue.

Neither of you listed your graphics chipset/version.INTEL what? (only some intel are suported) AMD radeon or nVidia? Im on a RadeonHD7850(x2) and STILL have this problem.I filed a bug too. I have 3d acceleration enabled and DRI/DRM working and still get this error on 21.Updates to 21 and fc22 dont have this issue unless you use fedup, which somehow breaks 3d acceleration yet again.This is a ZOMBIE bug.Moreso, I think its a GNOME3 fatal bug.GNOME3 is riddled with them.Installing cinnamon or mate is good workaround but it only highlights the issue.And last I checked from Debian, cinnamon breaks when you use 3d acceleration.The fact that you are running cinnamon tells me that your 3d acceleration is not working correctly.Maybe theres a core issue with X11 here? Libinput may affect some, but its not a kill-all. GNOME3 mostly works.

edit flag offensive delete link more
0

answered 2015-06-03 09:56:16 -0600

I have ThinkPad T500 and i had the same problem. Solution : uninstall xorg-x11-drv-libinput I found solution here: http://www.reddit.com/r/LinuxActionSh...

edit flag offensive delete link more

Comments

Thank you! I can finally log in to GNOME using X. Has the fedora team been informed that this is the culprit?

Sudo Noob gravatar imageSudo Noob ( 2015-06-03 15:47:19 -0600 )edit

Confirmed. Problem is solved by removing xorg-x11-drv-libinput.

Luis J gravatar imageLuis J ( 2015-06-04 03:41:10 -0600 )edit
0

answered 2015-11-10 06:08:54 -0600

hi all

I have been the same problem I have tried all the above and nothing worked. eventually I thought to

check the "Enable 3D acceleration" under settings --> display

edit flag offensive delete link more
0

answered 2016-10-05 03:21:35 -0600

Yeah i got same problem but i worked around like this now perfect everything

Ctrl +Alt+f2

Enter root username and password

sudo yum install upgrade

It will update takes sometime after completion take a reboot.

Thats all fedora 20 will be alright..

Regards Janardhan

edit flag offensive delete link more
0

answered 2015-06-04 04:05:59 -0600

whot gravatar image

Bug was filed here, the problem is that gnome tries to enable two-finger scrolling on a device that doesn't have two-finger scrolling and is unhappy when the driver responds with an error.

https://bugzilla.redhat.com/show_bug....

Simple workaround for now is: gsettings set org.gnome.desktop.peripherals.touchpad scroll-method "edge-scrolling"

edit flag offensive delete link more

Comments

The problem is that with the live DVD, I never get to a system where I can adjust the settings. A catch-22...

markito3 gravatar imagemarkito3 ( 2015-06-05 13:33:19 -0600 )edit

Same for me, could not install from Live DVD. As noted earlier, install from Server DVD was ok. And then install needed environments afterwards. Actually I like this better, more flexible, never understood idea behind Live anyway. This will be my preferred future install procedure.

kjafs gravatar imagekjafs ( 2015-06-06 14:56:43 -0600 )edit
0

answered 2016-03-04 15:02:44 -0600

odlefas gravatar image

This is terrible. Gnome has no fallback policy when "something went wrong". I had a problem with a sound driver that had to be black listed before Gnome would launch. Gnome should have come up to a working system without sound and then told me what the problem was. This is Linux. We do need better than Microsoft quality error responses. This is open source. We certainly do better than totally uninformative error messages and locked up machines, can't we?

edit flag offensive delete link more
0

answered 2015-06-25 18:31:59 -0600

For me it was different (though x complained about the keyboard compiler): I installed cinnamon

sudo dnf install @cinnamon-desktop

... and then it worked (albeit in software rendering, I guess I must install virtualbox guest addons first.

It was the second try of upgrading, in the first try the network did not get ipv4-IP so no "cleaunup" as mentioned int the fedUp wiki was possible => Stuck.

And then whoa, the fedup started a second time after reboot, not the new kernel...

I had also had to run grub-update to get the correct kernel enty, so maybe I was running the wrong kernel alltogether, who knows?

edit flag offensive delete link more
0

answered 2015-06-02 07:45:14 -0600

baoboa gravatar image

updated 2015-06-02 09:05:10 -0600

for fedora 22 gdm (login manager) start by default with wayland if not working should switch back to X11

did you try to disable wayland for gdm ?

see this post for how to do it #65310

see this bug bug#1218787 too

edit flag offensive delete link more

Comments

From my experience GDM works (disabled autologin)

Luis J gravatar imageLuis J ( 2015-06-02 08:46:02 -0600 )edit

GDM and Wayland isn't the problem. In fact, the GNOME Wayland session works just fine (despite the fact that Wayland is immature and not ready for everyday use)

Sudo Noob gravatar imageSudo Noob ( 2015-06-02 08:58:55 -0600 )edit

work for me too , but there is known bug for bi-gpu laptop bug#1218787

baoboa gravatar imagebaoboa ( 2015-06-02 09:02:36 -0600 )edit

Sorry, but probably I was not very clear. As in a my previous comment, I am also experiencing the "Oh no! Something has gone wrong..." with the live CD on a Lenovo T400 but not on an HP, both Core2Duo with integrated Intel graphics. When I disable the autologin (via /etc/gdm/custom.conf) I am able to reach the GDM login screen. The "Oh no! Something has gone wrong ..." is after the login. So, I believe it is not related with the wayland for GDM.

Luis J gravatar imageLuis J ( 2015-06-02 09:13:35 -0600 )edit

did you have a drm graphic driver then? lsmod | grep drm

baoboa gravatar imagebaoboa ( 2015-06-02 09:15:43 -0600 )edit

Question Tools

5 followers

Stats

Asked: 2015-05-29 09:57:58 -0600

Seen: 67,125 times

Last updated: Oct 05 '16