Ask Your Question
0

No sound harware detected when logged in as root user @fedora22

asked 2015-05-28 23:55:33 -0500

Santosh Ghimire gravatar image

updated 2015-05-28 23:57:45 -0500

sound icon also doesn't appears on gnome shell in root account ..

Is this same for all who have fedora 22 installed . Is this a bug ..?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-29 00:19:19 -0500

This is like noticing that your tire pressure is too low when you drive on the wrong side of the road. Don't log in to desktop environments as root.

edit flag offensive delete link more

Comments

have u faced the same problem ? i know about not logging as a root. i just would like to know if i was a bug.

Santosh Ghimire gravatar imageSantosh Ghimire ( 2015-05-29 00:36:12 -0500 )edit

You did something you shouldn't have, and got a result you shouldn't have. If you don't get sound as a regular user, I'd call it a bug.

randomuser gravatar imagerandomuser ( 2015-05-29 00:38:29 -0500 )edit

that wasn't answer to be posted under answer column by the way..

Santosh Ghimire gravatar imageSantosh Ghimire ( 2015-05-29 00:56:35 -0500 )edit

@Santosh: I used this 'pgrep alsactl | xargs kill -9; pulseaudio -D --log-target=syslog' . Helps temporarily, until the bug gets resolved. @randomuser: It's now like centuries people either know the response and let people have it, or don't know it and start saying 'Did you know you shouldn't log in as root user? blah blah blah' and fill the forums with useless bullshits. Out of the box, Fedora lets you log in as root user, does that mean anything to you? Come on, ain't people hearing they shouldn't log in as root since the ages being in diapers?

Mortoong gravatar imageMortoong ( 2015-06-11 08:19:15 -0500 )edit

Question Tools

Stats

Asked: 2015-05-28 23:55:33 -0500

Seen: 318 times

Last updated: May 29 '15