Ask Your Question
1

Fedora 22 + Win7 dual boot on separate disks. No bootloader.

asked 2015-05-27 12:33:34 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hello there,

Yesterday I installed Fedora 22 (+xfce) on my second Laptop (one HDD) and succesfully i can boot both Win7 and F22. But on this machine I have 1TB HDD and 120 GiB SSD. Win7 is on SSD, and Fedora is installed on one HDD. I did exactly what i did yesterday, using the same disk, but I have no choice to boot into Fedora. Just automaticaly boots into Windows. What can I do, to be able to boot into Fedora?

P.S. on HDD i have in sum 200GB for F22 (swap+/boot+/root+/home) and the rest is devided into two NTFS partitions.

edit retag flag offensive close merge delete

Comments

try to fix the bootloader with supergrub. This may help http://www.supergrubdisk.org/wizard-r...

b10n1k gravatar imageb10n1k ( 2015-05-27 14:44:09 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-28 07:26:11 -0600

pschindl gravatar image

You can try to boot directly from secondary disc (or set it in bios) this should work.

Anaconda probably used mbr from disk where you installed Fedora (sdb?). You can set it during installation in Installation destination it is on bottom left - Full disc summary and bootloader... -> Choose primary disc (both discs must be marked as destination for installation) and click on Set as Boot Device. Then it should boot to grub (where should be both Fedora and Windows).

On already installed system you can use command grub2-install <device> that will amend mbr of <device> so it will boot to grub from running system.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-27 12:33:34 -0600

Seen: 2,361 times

Last updated: May 27 '15