Ask Your Question
0

Where define keyboard layout for start-up?

asked 2015-05-19 21:07:10 -0600

florian gravatar image

When I boot my system, I do get a the keyboard language of my system language which is not the

  • one I want to use when starting up, and not the
  • one that was in use when shutting down.

How can I set a key using dconf-editor to define my standard keyboard language/layout or remember the last setting?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-20 00:55:08 -0600

Ahmad Samir gravatar image

When you're logged into GNOME, the order of the input sources seems to define the layout gnome-shell will use by default, e.g. on my box:

$ gsettings get org.gnome.desktop.input-sources sources
[('xkb', 'us'), ('xkb', 'ara')]

so it'll default to English us when I login, to change that to Arabic, reverse the order:

$ gsettings set org.gnome.desktop.input-sources sources "[('xkb', 'ara'), ('xkb', 'us')]"

you can use dconf-editor to edit that key; or use gnome-control-center -> Regional & Language, in the "Input Sources" section remove the input source at the top then re-add it (so that it's added after the input source you want to set as the default).

For the login screen, do the same after clicking the "Login screen" button in that dialogue.

edit flag offensive delete link more

Comments

Thanks for clarification.

florian gravatar imageflorian ( 2015-05-20 15:23:47 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-05-19 21:07:10 -0600

Seen: 745 times

Last updated: May 20 '15