Ask Your Question
1

How to turnoff automatic updates in fedora 21?

asked 2015-05-19 17:12:47 -0600

ddkroyal001 gravatar image

updated 2017-01-05 07:17:45 -0600

I want to stop all automatic updates for my system in fedora 21. I have seen many times in system monitor it consumes all bandwidth of my internet connection and things is being silently.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
4

answered 2015-05-20 01:47:47 -0600

Ahmad Samir gravatar image

In F21 there are two different components:

  1. since dnf is installed by default there's a background service that updates the repos metadata automatically (this is usually not that big, I'd say 20-50MB), you can disable that using systemctl, as root:

    systemctl disable dnf-makecache.timer

  2. IIUC gnome-software which downloads updates in the background then apply them offline, i.e. on next reboot, you can disable that using gsettings:

    gsettings set org.gnome.software download-updates false

or use dconf-editor to edit that key.

To update the system you can manaully use yum or dnf from terminal.

edit flag offensive delete link more
1

answered 2015-05-19 19:55:29 -0600

florian gravatar image

In general, Fedora21 does not install updates automatically unless you have it configured that way (using either yum-updatesd or an hourly/daily/weekly cronjob that executes something like su -c 'yum update', or yum-cron. Check the Fedora's wiki page for auto-update to see whether it's set-up on your system.

If by "turnoff automatic updates" you mean updating the metadata of your installed repos you do this: Open the yum config file /etc/yum.conf (sudo gedit /etc/yum.conf) an increase the value for metadata_ expire to your desired value. The higher this value the less frequent Fedora will download package information from the repos you have installed.

Nevertheless, I do not recommend not keeping the metadata up-to-date!

What you could do in order to use less bandwidth for your update process is using the parameter called bandwith in /etc/yum.conf (i.e. bandwidth=20%). Check out man yum.conf or this page for a description of the parameter and other neat stuff you can configure...

edit flag offensive delete link more

Comments

Yes installed yum-cron because it is recommended by the system. But after removing the yum-cron still it is consuming the bandwidth then i removed gnome-software, apper and unchecked all the option of yumex to make sure nothing would be download; still it is downloading the update. Yet i have not tried 'systemctl disable dnf-makecache.timer' , dconf-editor and yum-updatesd.

ddkroyal001 gravatar imageddkroyal001 ( 2015-05-20 03:37:06 -0600 )edit

i have tried :

yum-updatesd

*yum-updatesd

bash: yum-updatesd: command not found...

Install package 'yum-updatesd' to provide command 'yum-updatesd'? [N/y] n*

clearly yum-updatesd have no role.

systemctl disable dnf-makecache.timer

*[root@localhost ~]# systemctl disable dnf-makecache.timer

Removed symlink /etc/systemd/system/basic.target.wants/dnf-makecache.timer.*

dconf-editor

*[root@localhost ~]# dconf-editor

bash: dconf-editor: command not found...

Install package 'dconf-editor' to provide command 'dconf-editor'? [N/y] n*

ddkroyal001 gravatar imageddkroyal001 ( 2015-05-20 14:34:04 -0600 )edit

sudo gedit /etc/yum.conf

[main] cachedir=/var/cache/yum/$basearch/$releasever keepcache=0 debuglevel=2 logfile=/var/log/yum.log exactarch=1 obsoletes=1 gpgcheck=1 plugins=1 installonly_limit=3

clearly seen there no option to set the bandwidth limit. then how set it?

ddkroyal001 gravatar imageddkroyal001 ( 2015-05-20 14:43:14 -0600 )edit

just write it anywhere in the file: bandwidth=10%

(By default, this parameter is 0, and therefore no need to mention it in the file.)

florian gravatar imageflorian ( 2015-05-20 15:18:24 -0600 )edit

See also Ahmad's answer, especially point 2.

florian gravatar imageflorian ( 2015-05-20 15:19:23 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-05-19 17:12:47 -0600

Seen: 2,192 times

Last updated: Jan 05 '17