Ask Your Question
1

sebool not save after reboot PC

asked 2015-05-19 12:45:08 -0600

fahrul azmi gravatar image

updated 2015-05-20 19:49:12 -0600

mether gravatar image

to enable samba then I edit sebool samba with code "

su

Setsebool samba_export_all_rw ==> 1

Setsebool samba_share_fusefs ==> on

reboot

and I check again with the code "

su

Getsebool -a | grep samba

but the results are:

  • Samba_export_all_rw ==> off
  • Samba_share_fusefs ==> off

Please help me

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-05-19 16:13:49 -0600

sideburns gravatar image

Checking the man page for setsebool I find this:

   Without  the -P option, only the current boolean value is affected; the
   boot-time default settings are not changed.

Try again, with -P and it should work.

edit flag offensive delete link more
1

answered 2015-05-27 06:56:20 -0600

fahrul azmi gravatar image

u mean " getsebool -P | grep samba " is that correct.

Thanks

edit flag offensive delete link more

Comments

1

No. The option -P goes with setsebool, where you're setting the value. There is no -P option for getsebool as the man pages for the two commands will tell you. Trust man; man is your friend!

sideburns gravatar imagesideburns ( 2015-05-27 13:44:34 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-05-19 12:45:08 -0600

Seen: 107 times

Last updated: May 27 '15