Ask Your Question
1

SQL Developer in Fedora 21

asked 2015-05-19 09:55:24 -0600

anishjp gravatar image

updated 2015-05-19 09:57:51 -0600

Hi Guys

Has anyone managed to run Oracle SQL Developer in Fedora 21 with the new openJDK 1.8 version?

I get a "SQL Developer can't recognize the JDK version" error when trying to launch it from the terminal.

SQL Developer version

sqldeveloper-4.1.0.18.37-1.noarch.rpm

Java -version

openjdk version "1.8.0_45"
OpenJDK Runtime Environment (build 1.8.0_45-b13)
OpenJDK 64-Bit Server VM (build 25.45-b02, mixed mode)

My openjdk is located at

/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-35.b13.fc21.x86_64

I have added the above location to /opt/sqldeveloper/sqldeveloper/bin/sqldeveloper.conf

Set JavaHome /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-35.b13.fc21.x86_64
Set SkipJ2SDKCheck true

What could be wrong?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-06-28 06:11:39 -0600

anishjp gravatar image

I managed to fix it by using oracle java.

Download oracle jdk

rpm -ivh jdk-8***.rpm

Once the installation is done

Check the java home path

/usr/java/jdk1.8.0_45

Enter the above path to

/opt/sqldeveloper/sqldeveloper/bin/sqldeveloper.conf
Set javaHome /usr/java/jdk1.8.0_45

Open a terminal and lauch

sqldeveloper
edit flag offensive delete link more
1

answered 2015-05-19 10:37:42 -0600

Greetings!

First of all, Oracle suggests the usage of Oracle JDK instead of Open JDK although it is 'supported'.

This note from Oracle Documentation explains:

Although Oracle SQL Developer can run using OpenJDK, Oracle JDK is the Java requirement according to Oracle support and generally known to provide better stability and performance than OpenJDK.

I know the website says that any JDK 8 could be supported it is not totally true. Although SQL Developer works, it may fail.

My first suggestion would be install the Oracle JDK along with the Open JDK and execute the SQL Developer using the Oracle JDK.

Other suggestion is to edit again the file /opt/sqldeveloper/sqldeveloper/bin/sqldeveloper.conf with this corrections:

SetJavaHome /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.45-35.b13.fc21.x86_64
SetSkipJ2SDKCheck true

Hope this works for you.

Good luck!

edit flag offensive delete link more

Comments

@potty: thanks for your input!

anishjp gravatar imageanishjp ( 2015-06-28 06:12:45 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-05-19 09:55:24 -0600

Seen: 1,958 times

Last updated: Jun 28 '15