Ask Your Question
0

Problem to install gcc-c++ in fedora21 [closed]

asked 2015-05-19 00:10:17 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

*Installation of gcc-c++ in fedora21 64 bit is failed!!! The terminal command and outputs are given below:-*

g++ --version bash: g++: command not found... Install package 'gcc-c++' to provide command 'g++'? [N/y] y

  • Waiting in queue...
  • Loading list of packages.... The following packages have to be downgraded: gcc-4.9.2-1.fc21.x86_64 Various compilers (C, C++, Objective-C, Java, ...) cpp-4.9.2-1.fc21.x86_64 The C Preprocessor libgomp-4.9.2-1.fc21.x86_64 GCC OpenMP v3.0 shared support library libstdc++-4.9.2-1.fc21.x86_64 GNU Standard C++ Library libstdc++-4.9.2-1.fc21.i686 GNU Standard C++ Library The following packages have to be installed: libstdc++-devel-4.9.2-1.fc21.x86_64 Header files and libraries for C++ development Proceed with changes? [N/y] y

  • Waiting in queue...

  • Waiting for authentication...
  • Waiting in queue...
  • Requesting data...
  • Testing changes... Failed to install packages: Error running transaction: package libstdc++-4.9.2-1.fc21.x86_64 (newer than libstdc++-4.9.2-6.fc21.x86_64) is already installed package libstdc++-4.9.2-1.fc21.x86_64 (newer than libstdc++-4.9.2-6.fc21.i686) is already installed package libgomp-4.9.2-1.fc21.x86_64 (newer than libgomp-4.9.2-6.fc21.x86_64) is already installed package cpp-4.9.2-1.fc21.x86_64 (newer than cpp-4.9.2-6.fc21.x86_64) is already installed package gcc-4.9.2-1.fc21.x86_64 (newer than gcc-4.9.2-6.fc21.x86_64) is already installed package libstdc++-4.9.2-1.fc21.i686 (newer than libstdc++-4.9.2-6.fc21.x86_64) is already installed package libstdc++-4.9.2-1.fc21.i686 (newer than libstdc++-4.9.2-6.fc21.i686) is already installed
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by FranciscoD_
close date 2015-05-21 05:01:57.622078

2 Answers

Sort by » oldest newest most voted
0

answered 2015-05-19 01:53:22 -0600

geforce gravatar image

Can you post the output for this command

su
yum repolist

Please use the proper formatting (code tags) when posting as it makes it easier to understand

edit flag offensive delete link more
0

answered 2015-05-19 11:42:33 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Thanks, I installed it with sudo yum install g++

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-05-19 00:10:17 -0600

Seen: 1,064 times

Last updated: May 19 '15