Ask Your Question
2

How do I set arguments for rpc.gssd in /etc/sysconfig/nfs?

asked 2015-05-01 09:36:11 -0600

Jesse gravatar image

I've been using kerberized NFSv3 for a while now on older Fedora-like distributions (mainly CentOS) where I can configure the rpc.gssd executable's behavior by editing this file:

/etc/sysconfig/nfs

usually putting in this content, so that I can use a special keytab just for NFS:

SECURE_NFS="yes"
RPCGSSDARGS="-k /etc/some.alternate.keytab"

On a new install of Fedora 21 (with nfs-utils-1.3.1-2.0) mounts weren't working even after starting rpc-gssd.service, though manually running rpc.gssd did work. Eventually I found a solution in the rpc-gssd service file:

/usr/lib/systemd/system/rpc-gssd.service

I replaced GSSDARGS with RPCGSSDARGS, which matched the name I'm used to seeing in /etc/sysconfig/nfs.

#ExecStart=/usr/sbin/rpc.gssd $GSSDARGS
ExecStart=/usr/sbin/rpc.gssd $RPCGSSDARGS

I'd tried instead renaming the variable in /etc/sysconfig/nfs, but it had no effect. My question is, what variable name is the correct one, and is it documented anywhere? (I've only been able to find much older documentation from before the renaming of these services with the switch to systemd and all that.)

Thanks in advance!

edit retag flag offensive close merge delete

Comments

Reading over your description and comparing it to the F18 documentation shows that something got missed somewhere with the transition to NFSv4. Take a look at this and see if you can adapt your system to the current design.

https://docs.fedoraproject.org/en-US/...

danofsatx gravatar imagedanofsatx ( 2015-05-05 20:51:41 -0600 )edit

Thanks danofsatx! But, there's still nothing there about the options for /etc/sysconfig/nfs. I'd like to follow the right procedure for that file but it just doesn't seem to be documented anywhere, for either older versions or for 21. (I'm also still on NFSv3, though I don't think it'll matter in this case.)

Jesse gravatar imageJesse ( 2015-05-06 13:03:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-13 11:35:14 -0600

Jesse gravatar image

Aha! It's a bug in Fedora 21's nfs-utils:

https://bugzilla.redhat.com/show_bug....

There's a separate bug filed for what looks like the same problem in Fedora 22:

https://bugzilla.redhat.com/show_bug....

I updated to a version that should be fixed according to the F21 bug report (nfs-utils-1.3.1-6.3.fc21), but still see the same behavior, so I believe the bug is actually not yet fixed. But this does answer my question and I can follow the bug reports from here on.

Also, these versions of nfs-utils come with extensive comments inside a default /etc/sysconfig/nfs file which should help prevent confusion, lingering bugs aside.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2015-05-01 09:36:11 -0600

Seen: 827 times

Last updated: May 13 '15