Help with some yum update errors

asked 2015-04-25 20:03:19 -0500

Funkster12 gravatar image

updated 2015-04-25 23:58:11 -0500

skytux gravatar image

I tried installing ntopng which required some additional files be installed. I followed the instructions on the website for it which included epel and a few other things. When I try to do yum updates I get these errors after the dependencies are resolved. Any suggestions on how I fix this issue and proceed with a ntopng install?

Error: Package: gparted-0.19.1-3.el6.x86_64 (epel)
           Requires: hal >= 0.5.9
Error: Package: firebird-libfbembed-2.5.4.26856.0-1.el6.x86_64 (epel)
           Requires: libicudata.so.42()(64bit)
Error: Package: qtwebkit-2.3.4-6.fc20.x86_64 (updates)
           Requires: libwebp.so.4()(64bit)
           Removing: libwebp-0.3.1-3.fc20.x86_64 (@updates)
               libwebp.so.4()(64bit)
           Updated By: libwebp-0.4.3-3.el6.x86_64 (epel)
              ~libwebp.so.5()(64bit)
           Available: libwebp-0.3.1-2.fc20.x86_64 (fedora)
               libwebp.so.4()(64bit)
Error: Package: 2:ntfsprogs-2014.2.15-8.el6.x86_64 (epel)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)
Error: Package: satyr-0.15-2.el6.x86_64 (epel)
           Requires: librpm.so.1()(64bit)
Error: Package: firebird-libfbembed-2.5.4.26856.0-1.el6.x86_64 (epel)
           Requires: libicuuc.so.42()(64bit)
Error: Package: firebird-libfbembed-2.5.4.26856.0-1.el6.x86_64 (epel)
           Requires: libicui18n.so.42()(64bit)
Error: Package: python-pillow-2.2.1-7.fc20.x86_64 (@updates)
           Requires: libwebpmux.so.0()(64bit)
           Removing: libwebp-0.3.1-3.fc20.x86_64 (@updates)
               libwebpmux.so.0()(64bit)
           Updated By: libwebp-0.4.3-3.el6.x86_64 (epel)
              ~libwebpmux.so.1()(64bit)
           Available: libwebp-0.3.1-2.fc20.x86_64 (fedora)
               libwebpmux.so.0()(64bit)
Error: Package: 2:ntfsprogs-2014.2.15-8.el6.x86_64 (epel)
           Requires: libgnutls.so.26()(64bit)
Error: Package: python-pillow-2.2.1-7.fc20.x86_64 (@updates)
           Requires: libwebpdemux.so.0()(64bit)
           Removing: libwebp-0.3.1-3.fc20.x86_64 (@updates)
               libwebpdemux.so.0()(64bit)
           Updated By: libwebp-0.4.3-3.el6.x86_64 (epel)
              ~libwebpdemux.so.1()(64bit)
           Available: libwebp-0.3.1-2.fc20.x86_64 (fedora)
               libwebpdemux.so.0()(64bit)
Error: Package: skipfish-2.10-0.6.b.el6.x86_64 (epel)
           Requires: libpcre.so.0()(64bit)
Error: Package: perl-Regexp-IPv6-0.03-11.el6.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.10.1)
Error: Package: python-rsa-3.1.1-5.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Removing: python-2.7.5-15.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Updated By: python-2.7.5-16.fc20.x86_64 (updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-19.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: python-pillow-2.2.1-7.fc20.x86_64 (@updates)
           Requires: libwebp.so.4()(64bit)
           Removing: libwebp-0.3.1-3.fc20.x86_64 (@updates)
               libwebp.so.4()(64bit)
           Updated By: libwebp-0.4.3-3.el6.x86_64 (epel)
              ~libwebp.so.5()(64bit)
           Available: libwebp-0.3.1-2.fc20.x86_64 (fedora)
               libwebp.so.4()(64bit)
Error: Package: qpdf-libs-5.1.1-2.el6.x86_64 (epel)
           Requires: libpcre.so.0()(64bit)
Error: Package: webkitgtk3-2.2.8-3.fc20.x86_64 (@updates)
           Requires: libwebp.so.4()(64bit)
           Removing: libwebp-0.3.1-3.fc20.x86_64 (@updates)
               libwebp.so.4()(64bit)
           Updated By: libwebp-0.4.3-3.el6.x86_64 (epel)
              ~libwebp.so.5 ...
(more)
edit retag flag offensive close merge delete

Comments

But you are using Fedora? If you use Fedora, you can't use Epel repositories!

skytux gravatar imageskytux ( 2015-04-26 00:01:13 -0500 )edit