Ask Your Question
2

vpn and se-linux problem

asked 2015-04-15 16:29:04 -0600

dagrin gravatar image

I have installed the packages for using vpn, and filled out all the details for this service to run. But I get a error message from SELinux saying I need to move the certificate to the ~/.cert folder, but it isn't any folder by that name, only a file named ~/.cert. SELinux told me to "mv /home/dagr/Dokumenter/ca/ca.crt ~/.cert" I'm a little afraid of messing things up, but how do I solve this?

edit retag flag offensive close merge delete

Comments

1

move you certs to .cert folder in you home that will do the trick.

aeperezt gravatar imageaeperezt ( 2015-04-15 18:06:41 -0600 )edit

In Linux, any file or folder who's name starts with a dot is a hidden file/folder and doesn't normally show. You need to turn on Show Hidden Files to see it.

sideburns gravatar imagesideburns ( 2015-04-15 22:47:50 -0600 )edit
1

I see it. I deleted the file ~/.cert and made a folder with the same name. selinux gave some additional directions about making the certificate available for openvpn, but openvpn is still looking in the documents folder for the certificate. Now its both places and it works. Why does openvpn look in the documents folder and not the ~/.cert folder?

dagrin gravatar imagedagrin ( 2015-04-16 03:36:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2015-04-15 22:44:06 -0600

florian gravatar image

updated 2015-04-15 22:44:48 -0600

Follow SELinux' advice and copy (or move) the certs into the hidden folder .cert in you /home (~) directory. I had the same problem previously, and it got fixed.

Use: cp /home/dagr/Dokumenter/ca/ca.crt ~/.cert .cert is a folder, not a file.

You won't mess up anything, and if you copy the crt-file, you still have it at its original location.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-04-15 16:29:04 -0600

Seen: 324 times

Last updated: Apr 15 '15