Ask Your Question
1

Add Typography Layout

asked 2015-04-11 10:37:32 -0600

Mike B. gravatar image

updated 2015-04-15 09:39:08 -0600

florian gravatar image

How to add typography layout to Fedora 21? Under this kind of layout I mean something like Ilya Birman's Typography Layout.

I found some manual: http://alexeytorkhov.blogspot.co.il/2... :

$ setxkbmap -symbols 'pc+us+ru(typewriter):2+inet(evdev)+group(shifts_toggle)+level3(ralt_switch)+typo+typo:2'

Indeed, it added typography symbols, but now I'm not able to switch between the languages, which had worked before the change was made and part of the symbols are now replaced. Thus, I consider this manual as one, who breaks more than fixes. Is there any other way to add typography layout?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-04-15 09:26:16 -0600

florian gravatar image

updated 2015-04-15 10:11:43 -0600

Go to Settings --> Keyboard --> Input Sources.

There you click on the + to add a new keyboard (input source). Here you click on the three dots to show a wider selection. In the search field that appears you type English. In your results, search for English (international with AltGr keys).

This is what you are looking for, no?

image description

Now, you can easily toggle input sources using Super + Space or use the icon on top.

image description

Check out the various US- International, AltGr keyboards that are available. No clue, what there differences are in details but you can always display a keyboard map after adding the layout to your system.

edit flag offensive delete link more

Comments

Thanks, that's the right direction, but not exactly what I'm looking for. There is no built-in m-dash, arrows symbols. Also, I don't understand how can I type «…» symbol. I press the button and get «/ ¿ ?» chars, but not the «…».

BTW, is it difficult to create my own keyboard layout for Linux/Fedora?

Mike B. gravatar imageMike B. ( 2015-04-15 13:19:43 -0600 )edit

@mike-b: What's your mother tongue? US-English? Are you looking for the exact same layout as posted above ?

I just tested the following: I choose the keyboard layout English (US, international with dead keys), and I can find «…» symbols where it should be according to the keyboard map: AltGR + [ and AltGr + *].

florian gravatar imageflorian ( 2015-04-15 13:24:12 -0600 )edit

No clue how to create your own keyboard layout.

florian gravatar imageflorian ( 2015-04-15 13:36:58 -0600 )edit
1

My mother tongue is Russian, but what role does it play? I also added English (US, international with dead keys) and in the key map (click on the keyboard icon in Region & Language settings window) I see the symbol, but when I click on the right Alt I get ¿ char, if I press Shift, then ?, without any combination I got the / char. Did you succeed to type the symbol?

Mike B. gravatar imageMike B. ( 2015-04-15 13:45:38 -0600 )edit
1

I was asking about your mother tongue to find out what other dead key layout may fit your need. I need to test how it behaves here. Let you know later.

florian gravatar imageflorian ( 2015-04-15 21:15:06 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-04-11 10:37:32 -0600

Seen: 272 times

Last updated: Apr 15 '15