Ask Your Question
0

restoring win8.1 bootloader

asked 2015-04-11 07:03:49 -0600

bry6673 gravatar image

updated 2015-04-11 11:52:04 -0600

mether gravatar image

I am currently dual-booting Fedora 21(UEFI-native) and Windows 8.1. I need to restore the system to factory settings and have "reset" Windows for a fresh install. However, grub2 still remains and I need to restore the default Windows 8.1 bootloader.

Is there any documentation on how to properly restore the win8 bootloader after removing Fedora?

EDIT: I have tried booting to command prompt and then bootrec.exe /FixMbr and bootrec.exe /FixBoot with no success. It still comes up with the grub menu on every boot, and I have to manually select Windows from the list, even after deleting the linux partitions.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-11 11:06:41 -0600

cgonz31 gravatar image

If, as you say, F21 was installed in UEFI, then GRUB2 resides in the EFI System Partition (ESP). If W8 is installed in UEFI mode, then its bootloader is also located in the ESP, unless you erased the ESP when you installed F21. This is assuming that F21 was installed after W8.

Assuming the W8 bootloader is still present in the ESP, then all you need to is use the firmware UEFI bootloader. It can be accessed by pressing a key during POST. The key varies depending on the OEM but it's usually one of the F1-F12 keys, ESC, or DEL. The UEFI bootloader should list both F21 (which will take you to GRUB2) and W8.

In this case, to completely remove F21, delete all F21 partitions and delete the F21 files in the ESP. DO NOT delete the ESP, as this will result in an unbootable W8.

The second possibility is that the W8 files is installed in BIOS/Legacy/CSM mode. I doubt it is case but it is possible if you installed W8 yourself and/or F21 and W8 are installed in separate storage devices. I assumed that this is not the case. If it is, clarify this in the question.

edit flag offensive delete link more

Comments

This appeared to work. I mounted the EFI partition in Windows (mountvol b: /s), deleted the "fedora" directory and everything in it (might have been B:\EFI\fedora), and then unmounted the partition (mountvol b: /d). Now when I restart, it doesn't show a boot menu and Windows starts loading immediately. This is the behavior I wanted, I only hope I didn't screw anything up in the process. One would think that there would be a safer way to do this than manually deleting files from ESP and hoping for the best.

bry6673 gravatar imagebry6673 ( 2015-04-11 13:52:02 -0600 )edit

You probably could have used efibootmgr or your firmware setup screens to change the boot order, which would not destroy your ability to boot Fedora. It can remove boot entries, too, if you don't want to use Fedora any longer.

randomuser gravatar imagerandomuser ( 2015-04-11 15:32:04 -0600 )edit

If you just deleted the fedora folder in the ESP, you should be fine. You should have the PC as it was before you installed F21.

cgonz31 gravatar imagecgonz31 ( 2015-04-11 16:24:30 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-04-11 07:03:49 -0600

Seen: 380 times

Last updated: Apr 11 '15