Ask Your Question
0

Anaconda boot options/Graphics mode

asked 2015-04-10 07:56:41 -0500

george_____t gravatar image

updated 2015-04-10 16:38:03 -0500

Trying to install F21 on a windows 7 PC, via USB. Whenever I load the image off the USB, the system freezes within seconds, unless I use low graphics mode. However, this means that I can only install fedora with permanent low graphics mode (far from ideal).

I feel that changing the resolution in the installer would probably allow it to run normally, but when I try to append 'resolution=1024x768' for example to the boot options, it still runs in full resolution. In fact, adding any boot options, including 'vnc' or 'text' doesnt seem to change anything, the installer still runs in default mode. Even using 'xdriver=vesa', which I believe should have the same effect as low graphics mode, does not make any difference.

It's always possible that I've been a complete idiot and misunderstood how the boot options list is supposed to work, but anyway any help is greatly appreciated.

To make it clear, my process has been: boot from usb -> tab -> append space then 'resolution=1024x768' to the end of the options -> enter

Edit: I think my issue now seems to be swapping from the vesa driver to the correct nouveau driver. Although if anyone could give a hint as to why the boot options don't seem to be working, that would also be great.

edit retag flag offensive close merge delete

Comments

If you install in low resolution it do not means Fedora will be installed on low resolution on your pc, it means that the install image do not have the driver for your video card on the boot kernel, this will be added on install and on updates. It will help if you let us know what video card manufacture and model do you have.

aeperezt gravatar imageaeperezt ( 2015-04-10 09:34:24 -0500 )edit

Video card: NVIDIA GeForce 6150SE nForce 430 I've now tried installing the drivers for the card from rpmfusion and ended up breaking my existing fedora installation (plus side: the screen telling me the system was broken was in full resolution)

george_____t gravatar imagegeorge_____t ( 2015-04-10 13:04:17 -0500 )edit

Nvidia modules are always an issue if you use it you need to be careful with kernel updates as normally fedora speed of developing is faster than what Nvidia does so on updates you may lose your working config, in any case you can always use previous kernel to boot.

aeperezt gravatar imageaeperezt ( 2015-04-10 14:27:04 -0500 )edit

Ok, so if I stick to Nouveau, how do I install the correct driver? Updating the whole system didn't seem to make a difference.

george_____t gravatar imagegeorge_____t ( 2015-04-10 15:48:20 -0500 )edit

Thanks, that worked!

george_____t gravatar imagegeorge_____t ( 2015-04-17 05:55:05 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-12 07:58:25 -0500

Ahmad Samir gravatar image

updated 2015-04-17 12:25:23 -0500

If you installed in the non-default video mode for you card, then the installer adds "nomodeset" to the kernel command line; you can try removing it and see if the system boots to a graphical desktop:

  • At the grub screen press e

  • edit the line that beings with linux (or linuxefi if you have UEFI boot) and remove nomodeset

  • press F10 or Ctrl+x to boot that kernel

    EDIT: to make the changes permanent:

    • As root edit /boot/grub2/grub.cfg (or /boot/efi/EFI/fedora/grub.cfg) and remove nomodeset
    • As root edit /etc/sysconfig/grub and remove nomodeset from the GRUB_CMDLINE_LINUX entry so that subsequent runs of grub2-mkconfig doesn't add nomodeset back.
edit flag offensive delete link more

Comments

Hi! I had the same problem, i used the instructions you gave but the system wont work if i delete nomodeset. What should I do? Thanks

gionogio gravatar imagegionogio ( 2017-02-05 07:54:12 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2015-04-10 07:56:41 -0500

Seen: 3,047 times

Last updated: Apr 17 '15