Ask Your Question
0

Xmodmap on startup in fedora 21

asked 2015-04-09 16:14:51 -0600

Maxon gravatar image

I have custom key mappings in ~/.Xmodmap.

I have tried executing xmodmap ~/.Xmodmap without success in

  • .xinitrx
  • .xsession
  • /etc/X11/xinit/xinitrc
  • shell script in ~/.config/autostart/

The current Fedora documentation doesn't seem to cover this. The examples from Arch (which has really good docs) don't work.

Is this seriously such a rare use case?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-10 01:34:53 -0600

masteroman gravatar image

Are you using Gnome? If so, have you tried binding your custom key mappings in Gnome control center via "Keyboard" option?

edit flag offensive delete link more

Comments

Yes I am using Gnome. I cannot find any options to bind custom keys in the Keyboard settings. I can only change to another layout. Do I have to create a completely new layout for this to work? If so.. how would I go about and do it?

Maxon gravatar imageMaxon ( 2015-04-10 03:11:49 -0600 )edit

Option should be under Keyboard > Shortcuts, you just need to define your custom shortcut.

masteroman gravatar imagemasteroman ( 2015-04-11 06:16:07 -0600 )edit

I don't want to add a shortcut. I want to change my keyboard mapping.. as in make key a output b.

Maxon gravatar imageMaxon ( 2015-04-11 12:11:22 -0600 )edit

oh, sorry, I misunderstood you. :-/

masteroman gravatar imagemasteroman ( 2015-04-11 13:34:39 -0600 )edit

This is a known bug in GNOME.

What remapping do you want to do exactly? you can probably use a custom udev hwdb file to achieve that remapping on a very low level, i.e. that remapping will take effect for all users and in virtual terminals too.

Ahmad Samir gravatar imageAhmad Samir ( 2015-04-12 10:54:00 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-04-09 16:14:51 -0600

Seen: 1,052 times

Last updated: Apr 10 '15