Ask Your Question
2

f21 kernel issue

asked 2015-03-29 10:53:09 -0600

bry6673 gravatar image

Trying to get fedora21 working with my gaming laptop but after booting from a liveUSB stick it says an error has been detected in the kernel. The "install to hard drive" option doesn't work (nothing happens when you select it) and the entire system hangs to the point where it is unusable (ex: it takes about 10 minutes of waiting to open a terminal).

I am booting in UEFI-native mode and this is a requirement for other operating systems. The video card on the laptop is an nvidia GTX850M.

I managed to get the output of dmesg and found the following when searching for "error":

[    0.149301] ACPI Error: No handler for Region [EC__] (ffff88022704d090) [EmbeddedControl] (20140724/evregion-163)
[    0.149304] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20140724/exfldio-299)
[    0.149306] ACPI Error: Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._REG] (Node ffff88022704cfa0), AE_NOT_EXIST (20140724/psparse-536)
[    0.149366] ACPI Error: No handler for Region [EC__] (ffff88022704d090) [EmbeddedControl] (20140724/evregion-163)
[    0.149367] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20140724/exfldio-299)
[    0.149369] ACPI Error: Method parse/execution failed [\_SB_.PCI0.LPCB.EC__._REG] (Node ffff88022704cfa0), AE_NOT_EXIST (20140724/psparse-536)


[    3.739313] nouveau  [  PGRAPH][0000:01:00.0] using external firmware
[    3.739332] nouveau 0000:01:00.0: Direct firmware load for nouveau/nv117_fuc409c failed with error -2
[    3.739340] nouveau 0000:01:00.0: Direct firmware load for nouveau/fuc409c failed with error -2
[    3.739341] nouveau E[  PGRAPH][0000:01:00.0] failed to load fuc409c
[    3.739363] nouveau E[  DEVICE][0000:01:00.0] failed to create 0x18000717, -22
[    3.739385] nouveau E[     DRM] failed to create 0x00000080, -22
[    3.740209] nouveau: probe of 0000:01:00.0 failed with error -22


[    9.613734] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-3160-10.ucode failed with error -2

What do these errors mean? Is there anything that I can do to get fedora working with this laptop?

edit retag flag offensive close merge delete

Comments

That means the nouveau module for the nvida card cannot load the firmware try using compatibility video mode.

aeperezt gravatar imageaeperezt ( 2015-03-29 23:09:20 -0600 )edit

How can I use compatibility mode when booting from live USB stick?

bry6673 gravatar imagebry6673 ( 2015-03-30 13:00:39 -0600 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2015-04-01 14:36:27 -0600

The issue, unfortunately, is that your Maxwell GPU requires proprietary NVidia firmware to operate properly. Currently, the nouveau driver relies upon the extraction of this firmware and its placement into the /lib/firmware/nouveau directory in order to support nouveau's use of the GPU. So, in your log, you can see that nouveau detects this condition with your Maxwell GPU (using external firmware) and attempts to load the firmware it needs (Direct firmware load for nouveau/nv117_fuc409c). Because you have not extracted the firmware from the NVidia driver and placed it there, the load operation fails (failed with error -2) and nouveau cannot operate.

To make things easier on end users, the nouveau team provides a script which extracts the firmware from the NVidia driver for you. However, this script does not yet support Maxwell GPUs, so you would need to trace the firmware location in the binary yourself and extract it manually as explained here. You'd then need to modify your Live USB to include the firmware in the /lib/firmware/nouveau directory.

So you've got some legwork ahead of you, and it may not be worth it in the end if you don't intend to operate the machine in such a way that necessitates the use of the Maxwell GPU (I'm not sure what you intend to do with your Live-USB-driven laptop). Alternatively, you may have an Intel CPU (yes?) and you could try to rely on its integrated GPU for basic display functionality. If you do have such a CPU, you can try starting your machine with the kernel argument nouveau.modeset=0 to forcibly disable nouveau and see if the i915 driver is used in conjunction with your integrated Intel GPU.

OR you could go full UNIX on this problem and simply use a CLI only. =)

edit flag offensive delete link more

Comments

Great answer, thanks for that!

I'm thinking that manually exacting the firmware is more trouble than it's worth like you said. I do have such a CPU, that sounds like a good option to try. As far as setting that kernel argument when booting from the liveUSB, do I just hit e when the boot menu appears?

I only ask because I can't install and then configure it later since the system completely locks up due to these problems. I would need to boot from the liveUSB with this option.

bry6673 gravatar imagebry6673 ( 2015-04-02 15:25:40 -0600 )edit

Yup, you can just hit 'e' and append the kernel argument to the appropriate line. Let me know if that works or not, 'cause we might need to more explicitly instruct the system to make use of the i915 module.

bitwiseoperator gravatar imagebitwiseoperator ( 2015-04-02 16:08:31 -0600 )edit

Looks like my comment got erased, guess I'll type it again.

It looks like that fixed the issue! I just need to figure out how to edit and update the grub config files to make it boot with the modeset=0 every time, and to make windows the default.

One strange observation, there is a LED which is supposed to show which GPU is being used (blue for intel and orange for nvidia). Despite the modeset=0, it still shows orange. Probably not important, just something I noticed.

Do you think the ACPI error is important? Maybe I should open another question for that.

Thanks for your help!

bry6673 gravatar imagebry6673 ( 2015-04-02 20:05:13 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-03-29 10:53:09 -0600

Seen: 1,054 times

Last updated: Mar 29 '15