Ask Your Question
1

fsck is running every time fedora 21 boots

asked 2015-03-27 03:27:10 -0600

deadrat gravatar image

updated 2015-04-11 12:53:49 -0600

Fedora 19, 20 were working very good. Then I installed (fresh install) fedora 21 and it was working fine too, but then I installed many things and changed few things. Even now it works fine, but startup is very slow. It was getting to my desktop screen in about 10 seconds when I first installed it. But now it takes about 2 minutes to get to desktop screen.

fsck is running every time fedora 21 boots and it considerably slows down the boot time.

What I remember about changing in fedora:

  • Installed many applications like SM Player, Vlc, tor, gimp e.t.c.
  • I also installed Google Chrome, teamviewer,
  • I made two NTFS HDD partitions to mount automatically on boot/startup.

If these files are helpful, please have a look at my plot.svg and blame.txt

Here is my boot log. Please use zxcv to access it.

edit retag flag offensive close merge delete

Comments

1

One thing that jumps out of me is systemd-fsck-root.service taking up over 31 seconds. Does this service take that much time on every boot, and if so, why? (On my computer, it took 5.240s on the last boot.) You might also want to run systemd-analyze critical-chain to see if that's holding other things up.

sideburns gravatar imagesideburns ( 2015-03-27 03:52:19 -0600 )edit

Everytime it boots up, it runs something like /dev/mapper/fedora-root: fschk and it goes from 0 to 100 % it usually takes about 25 seconds.

deadrat gravatar imagedeadrat ( 2015-03-27 05:09:23 -0600 )edit

When I ran systemd-analyze critical-chain the output I got is http://ur1.ca/jzz0w

deadrat gravatar imagedeadrat ( 2015-03-27 05:13:03 -0600 )edit

What filesystem are you using for your root partition?

mad2 gravatar imagemad2 ( 2015-03-27 09:08:14 -0600 )edit
1

I see that systemd-fsck-root.service is down near the bottom of the critical chain, meaning that there are a lot of things that can't even start until it's finished. Finding out why it takes so long and correcting whatever's wrong would cut about 30 seconds from your boot time. It's not the complete answer, but it's a step in the right direction.

sideburns gravatar imagesideburns ( 2015-03-27 15:12:02 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2015-03-29 21:51:46 -0600

sideburns gravatar image

I think I've found the answer to your issue with fsck: man systemd-fsck-root.service tells me that the service understands one kernel command line parameter:

fsck.mode=
           One of auto, force, skip. Controls the mode of operation. The
           default is auto, and ensures that file system checks are done when
           the file system checker deems them necessary.  force
           unconditionally results in full file system checks.  skip skips any
           file system checks.

It's quite possible that you have this set to force. If so, try changing it to auto; if that works, you can remove the line completely. If not there may be some reason that the checker thinks it needs to run at every boot, and we need to look into that. If so, we'll work on fixing that, but let's not borrow trouble.

edit flag offensive delete link more

Comments

Thanks for the answer @sideburns .

I am sorry, but I am not technically that sound. Please instruct me like how u instruct a beginner. So How to change fsck.mode to auto. I tried searching about it, but I couldn't find the answer.

Should I add a line to fstab?

deadrat gravatar imagedeadrat ( 2015-03-30 00:11:30 -0600 )edit
1

No. This has nothing to do with fstab. The next time you boot, you need to edit the command line, removing anything that says fsck.mode= and of course, the value itself. (auto, force or skip) Then, boot that way and see what happens. If that works, we'll need to find out how to remove it permanently, as I don't know off-hand; if not, we'll just keep trying.

sideburns gravatar imagesideburns ( 2015-03-30 02:10:34 -0600 )edit

I tried, but it happens again.

I guess I am the only person facing this issue. If that is the case, I don't think it is good to waste time on this. I 'll re install the OS or maybe I will try fedora 22 beta once it is available and that should fix the issue, hopefully. (I do not want to try alpha release as it is my only and primary PC and I am bit afraid to try alpha in my primary PC. :) )

Thank you very much for helping @sideburns. (+1 for your answer and comments. ). Thank you @hedayat .

deadrat gravatar imagedeadrat ( 2015-03-31 01:34:02 -0600 )edit

You're welcome. But, exactly since almost only you are facing this issue, don't expect it to be fixed by F22; this is very unlikely to be a F21 bug. @sideburns hint about clock problem is very likely, because fsck will check the filesystem if it's umount time is in future.

If the link he said didn't work, we can try running fsck manually in dracut shell to see WHY it thinks that it should check your filesystem (as it itself guessed that there is a clock problem, and fixed the time, I wonder if it'll continue checking in this case).

hedayat gravatar imagehedayat ( 2015-03-31 02:35:37 -0600 )edit

me too facing same same issue i guess, as i did synchronized clocks according to instructions in that thread but it didnt help. still checking fs everytime because superblock write time is in future...

Deval gravatar imageDeval ( 2015-04-01 07:16:35 -0600 )edit
1

answered 2015-04-03 08:08:38 -0600

rg3 gravatar image

As suggested in other answers, you're probably hitting a known bug. Please see comment #5 here:

https://bugzilla.redhat.com/show_bug....

And a related recent thread in the unofficial Fedora forums I created.

http://forums.fedoraforum.org/showthr...

Long story short: create the file in /etc/dracut.conf.d as suggested in the comments. Then, run dracut -f. Reboot. It should be fixed even if new kernels are installed and new initial RAM disks are created.

edit flag offensive delete link more
1

answered 2015-04-03 02:54:20 -0600

hedayat gravatar image

updated 2015-04-03 05:33:08 -0600

I rebooted my system today, and faced the same issue. Therefore, I'd say this is certainly a bug. (I've configured my system to have RTC in localtime rather than UTC. If you have configured your system likewise, the problem might be related to this).

Anyway, I'm going to report this as a bug

Edit: It is already reported as a bug: https://bugzilla.redhat.com/show_bug....

Notice: Apparently, it only happens if: 1. Your RTC is set to local time 2. Your time is ahead of UTC (+ rather than -)

What can be done for NOW:

  1. Change your RTC time to UTC (recommended). If you have a dual-boot system, you should change this setting in other OS(es) too, e.g. in Windows this can be done through some registry key (IIRC). (recommended)
  2. Turn off fsck for / partition in /etc/fstab
edit flag offensive delete link more

Comments

There is no optionto choose the time zone for RTC and yes it is in local time. I follow IST which is 5.5 hours ahead of UTC.

I will try changing the time and update results. Thank you.

deadrat gravatar imagedeadrat ( 2015-04-07 11:39:30 -0600 )edit

You can use this to change your RTC to UTC:

timedatectl set-local-rtc 0

It'll modify /etc/adjtime and will change RTC time to UTC. However, if you've other OSes, you should modify their settings too.

hedayat gravatar imagehedayat ( 2015-04-11 04:07:01 -0600 )edit

Question Tools

4 followers

Stats

Asked: 2015-03-27 03:27:10 -0600

Seen: 1,754 times

Last updated: Apr 11 '15