Ask Your Question
0

insmod: ERROR: could not insert module mymodule.ko: Operation not permitted

asked 2015-03-18 11:31:25 -0500

Paulpandian gravatar image

I have generated the .ko for my testing.

But I can not able to insmod this, its giving the below error insmod: ERROR: could not insert module mymodule.ko: Operation not permitted

I have searched this is google, found need to disable the secure boot, but in my PC if I am disabling the secure boot this is bootingup the windows, I can not get my linux PC boot.

Please suggest for this insmod issue.

edit retag flag offensive close merge delete

Comments

If you are are using UEFI on you PC and you have it as secure mode, then your module should be sign. To sign your module you need to do somehting like this https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/sect-signing-kernel-modules-for-secure-boot.html .

Not done my self actually google it I think there is another response with about the same issue. Hope this help or point you into the right direction

aeperezt gravatar imageaeperezt ( 2015-03-18 11:44:55 -0500 )edit

Also check this answer https://ask.fedoraproject.org/en/question/65473/virtualbox-error/ it detail a method to create a key for secure boot

aeperezt gravatar imageaeperezt ( 2015-03-19 17:22:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-19 05:20:51 -0500

jjv gravatar image

updated 2015-03-19 17:03:47 -0500

To be able to insert modules into the kernel you have to be root. Also, it's better to use modprobe than insmod. Try the following command:

sudo modprobe mymodule
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-03-18 11:31:25 -0500

Seen: 9,951 times

Last updated: Mar 19 '15