Ask Your Question
0

Huawei e3372 not working

asked 2015-03-18 08:56:12 -0600

SaraBe gravatar image

updated 2015-05-25 20:53:09 -0600

mether gravatar image

Hi,

I've been trying Fedora 21 and Fedora 22. While Fedora 21 detects the device itself and the network operator "Play Online" (Poland) correctly, it doesn't show any Billing Plan, and after the configuration it spends a long while trying to connect (the blue LED on the device shines then constantly). Then, the system gives up (LED off). Fedora 22 doesn't detect the device at all.

I've been trying to follow this tutorial:

http://www.modemunlock.com/huawei-linux-driver-download-and-installation.html

It gave a lot of errors during installation, saying that only modem will work. This didn't however seem to affect the system's or device's behaviour.

This issue applies to both 32 bit and 64 bit, KDE and Gnome, tested on two totally different laptops. Entering the PIN code, and/or manipulating with Verification Methods didn't help at all.

Additiionally it seems to go the same way on every Linux distribution that is based on RPM packages (PCLinuxOS, Fedora 21, 22,Rosa Linux, Manjaro, Open Mandriva), while the modem works just out-of-the-box on DEB distributions i've tested (*buntu, Mint, Debian).

Any ideas, please?

EDIT

journalctl -f reports this:

I made in bold what seems to me important.


mar 18 16:31:07 ASUS-X401A1 NetworkManager[762]: <info> Activation (cdc-wdm0) starting connection 'Play Online Domyślne' mar 18 16:31:07 ASUS-X401A1 NetworkManager[762]: <info> Activation (cdc-wdm0) Stage 1 of 5 (Device Prepare) scheduled... mar 18 16:31:07 ASUS-X401A1 NetworkManager[762]: <info> Activation (cdc-wdm0) Stage 1 of 5 (Device Prepare) started... mar 18 16:31:07 ASUS-X401A1 NetworkManager[762]: <info> (cdc-wdm0): device state change: disconnected -> prepare (reason 'none') [30 40 0] mar 18 16:31:07 ASUS-X401A1 NetworkManager[762]: <info> NetworkManager state is now CONNECTING mar 18 16:31:07 ASUS-X401A1 NetworkManager[762]: <info> Activation (cdc-wdm0) Stage 1 of 5 (Device Prepare) complete. mar 18 16:31:07 ASUS-X401A1 ModemManager[658]: <info> Simple connect started... mar 18 16:31:07 ASUS-X401A1 ModemManager[658]: <info> Simple connect state (4/8): Wait to get fully enabled mar 18 16:31:07 ASUS-X401A1 ModemManager[658]: <info> Simple connect state (5/8): Register mar 18 16:31:07 ASUS-X401A1 ModemManager[658]: <info> Simple connect state (6/8): Bearer mar 18 16:31:07 ASUS-X401A1 ModemManager[658]: <info> Simple connect state (7/8): Connect mar 18 16:31:07 ASUS-X401A1 ModemManager[658]: <info> Modem /org/freedesktop/ModemManager1/Modem/0: state changed (registered -> connecting) mar 18 16:31:07 ASUS-X401A1 NetworkManager[762]: <info> (cdc-wdm0): modem state changed, 'registered' --> 'connecting' (reason: user-requested) mar 18 16:31:08 ASUS-X401A1 ModemManager[658]: <info> Modem /org/freedesktop/ModemManager1/Modem/0: state changed (connecting -> connected) mar 18 16:31:08 ASUS-X401A1 ModemManager[658]: <info> Simple connect state (8/8): All done mar 18 16:31:08 ASUS-X401A1 NetworkManager[762]: <info> (cdc-wdm0): modem state changed, 'connecting' --> 'connected' (reason: user-requested) mar 18 16:31:08 ASUS-X401A1 NetworkManager[762]: <info> Activation (cdc-wdm0) Stage 2 of 5 (Device Configure) scheduled... mar 18 16:31:08 ASUS-X401A1 NetworkManager[762]: <info> Activation ... (more)

edit retag flag offensive close merge delete

Comments

Well, normally the USB modems works in Fedora without installing any custom drivers. Take a fresh Fedora 21 and create a profile for your network provider and post the output results.

anishjp gravatar imageanishjp ( 2015-03-19 02:44:57 -0600 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2015-03-30 01:18:17 -0600

deadrat gravatar image

updated 2015-03-30 01:22:03 -0600

It is not necessary to install any driver for this device on fedora. I have used this Huawei e3372 in fedora 20 without need for installing any driver. You should be able to use it just by configuring it via network manager. If you want additional options, you may install ModemManager by simply typing sudo yum install modem-manager-gui in terminal. Then you can find the application Modem Manager GUI in applications and you can run it to use your mobile broadband.

edit flag offensive delete link more
0

answered 2015-05-25 18:51:14 -0600

Sarah gravatar image

updated 2015-06-05 03:59:01 -0600

In Fedora =< 20 the modem works just out-of-the-box. However I would prefer not to be stuck on those while tomorrow comes the newest one. The modem-manager-gui returns just this:

Error while initialization No one modem manager available

post the output results.

Results from where? System just notifies that it is connecting, then after a while, that it is disconnected. I have dug out that it cannot get the IP Address from the network. Through this:

journalctl -f

I got this:

|...] NetworkManager |762]: <info> (cdc-wdm0): device state change: ip-config -> failed (reason 'ip-config-unavailable') |70 120 5] |...]

I've replaced the [ symbols with |, because otherwise the line kept disappearing. ;-p

EDIT:

Clean Fedora 22 install doesn't even list the modem, so I can't configure it.

EDIT 2:

sara@localhost:~$ journalctl -f -- Logs begin at śro 2015-05-27 06:21:59 CEST. -- cze 05 10:39:46 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING : STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:40:05 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:40:12 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:40:12 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:40:12 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:40:15 localhost.localdomain /usr/libexec/gdm-x-session[888]: Activating service name='org.gnome.Terminal' cze 05 10:40:17 localhost.localdomain /usr/libexec/gdm-x-session[888]: Successfully activated service 'org.gnome.Terminal' cze 05 10:40:19 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:40:19 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:40:20 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:41:04 localhost.localdomain NetworkManager[644]: <info> NetworkManager state is now CONNECTED_GLOBAL cze 05 10:41:27 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:41:31 localhost.localdomain gnome-control-center.desktop[2377]: (gnome-control-center:2377): GLib-GObject-WARNING *: The property GtkCellRendererPixbuf:follow-state is deprecated and shouldn't be used anymore. It will be removed in a future version. cze 05 10:41:33 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:41:33 localhost.localdomain gnome-session[958]: (gnome-shell:1169): mutter-WARNING *: STACK_OP_RAISE_ABOVE: window 0x5a00c00017 not in stack cze 05 10:41:41 localhost.localdomain gnome-control-center.desktop[2377]: (gnome-control-center:2377): GLib-GObject-WARNING *: The property GtkMisc:xalign is deprecated and shouldn't be used anymore. It will be removed in a future version. *cze 05 10:41:42 localhost.localdomain dbus[529]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service' cze 05 10:41:42 localhost.localdomain dbus[529]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManager1.service ... (more)

edit flag offensive delete link more

Comments

I haven't used a modem-manager-gui (never had to because the existing gnome-network-manager gui works out of box).

anishjp gravatar imageanishjp ( 2015-09-21 02:50:02 -0600 )edit
0

answered 2015-09-17 13:54:02 -0600

haraldmu gravatar image

I got the same issue with a HUAWAI 3372 and ailed (reason 'ip-config-unavailable') |70 120 5] |.

Any success in the meantime?

Harald Mueller

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-03-18 08:56:12 -0600

Seen: 4,045 times

Last updated: Jun 05 '15