Ask Your Question
0

Fresh install of Fedora 21 freezes on boot

asked 2015-02-15 22:59:47 -0600

Cicada gravatar image

updated 2015-02-16 03:25:23 -0600

Hello! Linux newbie here. I installed Fedora 21 just yesterday from a live DVD, but while the DVD itself worked fine the first time I tried to boot from it and the second time I loaded up Fedora after installing, I'm now experiencing some issues. Whenever I try to start the computer up, it loads the GRUB, but then freezes on a blank screen with nothing but a flashing cursor (this happened the first time I tried to boot it after installing as well). I cannot type anything, and not even the power button will respond. I have yet to find a way to escape this screen except to pop out the battery and unplug. When I tried to reinstall, I discovered that the CD had started doing the same thing.

After digging through some people with similar issues in the past, I discovered someone who had solved their problem by typing "intel_iommu=off" into the GRUB. This worked twice, but only when I typed it in, turned the computer off, and then turned it back on again. It would only work the one time before I would have to do it again. However, now that isn't working at all, so I'm not sure if it was coincidence or if it just doesn't work.

I thought that it may have been the result of a faulty installation disc, but the checksum of the .iso I downloaded was just fine. So, unless my burning program corrupted it, which is certainly possible but not something I know how to check, it's not my disc. At this point I just admitted I have no idea what I'm doing, gave up, and decided to come here for help.

Currently using an ASUS U46E with an Intel graphics card, and I am dual booting with Windows 7, which works perfectly fine.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-07-04 23:39:14 -0600

Cicada gravatar image

Ah! I forgot to answer this, didn't I? Some digging told me that other people with my laptop model (Asus U46E) had this same problem, so chances are it's simply that it isn't compatible with the hardwar. However, there is a workaround. All you need to do is add the noapic command to the kernel. To do this, press "e" in the GRUB menu and find the line that starts with "linux". At the very end of that line, add a space and type "noapic". Once you've done that, it should boot fine!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-02-15 22:59:47 -0600

Seen: 2,124 times

Last updated: Feb 15 '15