Ask Your Question
0

Unable to update software using yum in Fedora 21

asked 2015-01-16 08:46:38 -0600

rahulruns gravatar image

updated 2015-03-15 13:55:04 -0600

FranciscoD_ gravatar image

I am trying to update fedora 21 softwares using yum and I tried all solutions that are listed in askfedora but still I am not able to resolve it. Now I am clueless what is the issue which is causing it. The error which I get is

[root@localhost ~]# yum check-update 
Loaded plugins: langpacks
adobe-linux-i386                                                                                                               |  951 B  00:00:00     
Could not get metalink http://mirrors.fedoraproject.org/metalink?repo=fedora-21&arch=i386 error was
14: curl#7 - "Failed to connect to mirrors.fedoraproject.org port 80: Network is unreachable"
google-chrome                                                                                                                  |  951 B  00:00:00     
https://mirrors.fedoraproject.org/publiclist/Fedora/21/i386/repodata/repomd.xml: [Errno 14] curl#7 - "Failed to connect to mirrors.fedoraproject.org port 443: Network is unreachable"
Trying other mirror.
https://mirrors.fedoraproject.org/publiclist/Fedora/21/i386/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.


 One of the configured repositories failed (added from: https://mirrors.fedoraproject.org/publiclist/Fedora/21/i386/),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable mirrors.fedoraproject.org_publiclist_Fedora_21_i386_

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=mirrors.fedoraproject.org_publiclist_Fedora_21_i386_.skip_if_unavailable=true

failure: repodata/repomd.xml from mirrors.fedoraproject.org_publiclist_Fedora_21_i386_: [Errno 256] No more mirrors to try.
https://mirrors.fedoraproject.org/publiclist/Fedora/21/i386/repodata/repomd.xml: [Errno 14] curl#7 - "Failed to connect to mirrors.fedoraproject.org port 443: Network is unreachable"
https://mirrors.fedoraproject.org/publiclist/Fedora/21/i386/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
[root@localhost ~]#

EDIT:

Have tried yum clean all and yum update but still same result. The output of yum repolist all is

[root@localhost yum.repos.d]# yum repolist all
Loaded plugins: langpacks
adobe-linux-i386                                                                                                               |  951 B  00:00:00     
Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-21&arch=i386 error was
14: curl#7 - "Failed to connect to mirrors.fedoraproject.org port 443: Network is unreachable"
google-chrome                                                                                                                  |  951 B  00:00:00     
https://mirrors.fedoraproject.org/publiclist/Fedora/21/i386/repodata/repomd.xml: [Errno 14 ...
(more)
edit retag flag offensive close merge delete

Comments

2

Try sudo yum clean all and then sudo yum check-update. Also post the output of yum repolist all.

cgonz31 gravatar imagecgonz31 ( 2015-01-16 09:27:42 -0600 )edit

very simple, disable "google-chrome"

su

gpk-prefs
davidva gravatar imagedavidva ( 2015-01-16 19:52:54 -0600 )edit

No idea what's wrong. I have never had yum issues so I thought the clean command might help. Other than this, I don't know how to troubleshoot yum issues.

cgonz31 gravatar imagecgonz31 ( 2015-01-16 23:11:56 -0600 )edit

Same problem here. Cleaning or gpk-prefs disable google-chrome doesn't help

Raulucco gravatar imageRaulucco ( 2015-03-05 14:45:03 -0600 )edit

I got the same message as above when I tried to remove the nvidia on my desktop, using 'rpm - e' command as it was causing a grey screen problem on reboot of Fedora 21. I am new to this however and not sure how to 'contact the upstream'..?

aqua gravatar imageaqua ( 2015-03-15 03:45:09 -0600 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2015-04-02 19:39:12 -0600

the command "gpk-prefs" works for me on Fedora21. After type in, it will pop out a window, and I checked all the options. Then run the command "yum repolist", you can see more update sources added.

edit flag offensive delete link more
0

answered 2015-04-03 16:21:05 -0600

waqas gravatar image

i had same problem and i am using a proxy. so i did the following and it works for me. first i enter

yum-config-manager --save --setopt=updates.skip_if_unavailable=true

then i applied the second code given in the possible fix of this error.the code is sudo yum-config-manager --disable updates after this i edit yum.conf file in /etc and added the following proxy=http://my_proxy_address:port

after this i run yum update and it works fine now. i don't know which of the above did the actual job. but at last i got it working.

edit flag offensive delete link more
0

answered 2016-01-07 04:17:14 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

yum-config-manager --save --setopt=updates.skip_if_unavailable=true then i applied the second code given in the possible fix of this error.the code is sudo yum-config-manager --disable >> updates after this i edit yum.conf file in /etc and added the following proxy=http://my_proxy_address:port

Worked fine with me.. Thanks a lot

edit flag offensive delete link more
0

answered 2015-07-15 00:50:35 -0600

Bharat gravatar image

Another possible solution.

I had this same issue. The internet is accessible via a proxy server and I had done many updates and OS upgrades without any issue. Suddenly my yum started throwing the HTTP 401 error. I finally figured out that I had to change proxy=http://<IP> in the /etc/yum.conf file to proxy=https://<IP>.

There was some changes in our proxy server settings that I was unaware of.

So this might also be one of the solutions. In general, if you face this error then try these (just a summary of different sources):

  • run yum clean all
  • add this line ipresolve=4 in /etc/yum.conf
  • Check the proxy settings and set proxy address to https instead of http
edit flag offensive delete link more
-1

answered 2015-03-15 04:38:30 -0600

Urdo gravatar image

updated 2015-03-15 04:40:37 -0600

I'm not a linux guru so I have installed "Yumex". When you start Yumex it begins with looking for updates, give a list of updates, so you can select the updates you wants. I know yumex is for newbees ( as my son says) but for me it works. Urdo.

edit flag offensive delete link more

Comments

1

This doesn't answer the ops question at all. :(

FranciscoD_ gravatar imageFranciscoD_ ( 2015-03-15 13:53:01 -0600 )edit

Just a few clarifications... 1. Yumex isn't for newbies, there are simpler package manager. I use it when looking for software to install, it makes it easy to see what's in the repos. 2. It uses 'yum' under the hood to do all it's work. If yum is failing, then yumex will fail in exactly the same way.

cobra gravatar imagecobra ( 2015-07-15 10:28:02 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2015-01-16 08:46:38 -0600

Seen: 7,465 times

Last updated: Apr 03 '15