Ask Your Question
1

Libraries i965_dri and swrast_dri for legacy code in Fedora 21

asked 2014-12-16 12:01:27 -0600

alfC gravatar image

I am using a legacy application (Acrobat Reader 9.4.1), when I try to load a PDF with 3D information and try to render from Hardware I get this error:

libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Where can I find these libraries in Fedora 21? I don't remember having this problem in Fedora 20.

Related: https://bbs.archlinux.org/viewtopic.php?id=157117 (but *intel-dri is not in Fedora 21).

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-11-27 18:14:04 -0600

bayprogrammer gravatar image

To allow a 32 bit binary to work that complained about missing i965_dri.so and swrast_dri.so on my 64 bit install of Fedora 25 Workstation I needed to install mesa-dri-drivers.i686. I also installed xorg-x11-drv-intel.i686, but I'm not certain yet if that was necessary. This binary (a game, not Adobe Reader) also wanted several other 32 bit libs that I had to iteratively figure out, but for that specific requirement installing these two packages satisfied the dependency.

To install those:

$ sudo dnf install xorg-x11-drv-intel.i686 mesa-dri-drivers.i686

edit flag offensive delete link more

Comments

Thanks, I couldn't succeed in starting trine2 and this helped. I think this will help also people with steam.

akiross gravatar imageakiross ( 2017-01-16 18:27:21 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-12-16 12:01:27 -0600

Seen: 3,199 times

Last updated: Nov 27 '16