Ask Your Question
1

How can I force Firefox to use icedtea plug in (instead of Oracle's)

asked 2014-12-15 14:35:50 -0600

alfC gravatar image

I have installed Oracle's Java and IcedTea Java. How can I force Firefox to use the the IcedTea one? So far it always opens Oracle's 8.0 :(

I also tried uninstalling Oracle's Java, but I can't.

I am on Fedora 21. (I am seriously considering reinstalling the whole system since Oracle's Java made a mess with the yum system and the alternatives system)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-12-15 23:50:31 -0600

You are fine. You just need to tell your system what alternative version of Java browser plugin it should use.

See the answer here.

edit flag offensive delete link more

Comments

Ok, this worked alternatives --config libjavaplugin.so.x86_64 in the sense that it forced the IcedTea plugin. Java tester gives lots of errors still. Something seems to be broken.

alfC gravatar imagealfC ( 2014-12-16 12:45:38 -0600 )edit

As always one finds out (after the fact) that rebooting helped clearing up the issues.

alfC gravatar imagealfC ( 2014-12-17 01:44:32 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-12-15 14:35:50 -0600

Seen: 3,877 times

Last updated: Dec 15 '14