Ask Your Question
0

module command not found in Fedora 21

asked 2014-12-11 21:42:43 -0600

alfC gravatar image

I used to do things like:

module load mpi/openmpi-x86_64

To compile and run in a certain environment. However in Fedora 21

$ module
bash: module: command not found...

And I can't find how to install module command.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-12-12 00:08:21 -0600

pnemade gravatar image

You need to install environment-modules package

sudo yum install environment-modules
edit flag offensive delete link more

Comments

It was installed. I found that loading /etc/profile from .bashrc made it work. Is this the optimal solution?

alfC gravatar imagealfC ( 2014-12-12 01:02:13 -0600 )edit

/etc/profile scripts are automatically loaded at login, no need to include this in ~/.bashrc.

marcindulak gravatar imagemarcindulak ( 2014-12-14 23:59:35 -0600 )edit

Ok, I don't know, but that was the way I made it work. could it be that it is a pure Fedora 21 issue?

alfC gravatar imagealfC ( 2014-12-15 13:48:56 -0600 )edit

Is module even an executable. module avail works, while which module doesn't find anything.

alfC gravatar imagealfC ( 2015-01-09 15:21:27 -0600 )edit

I am in Fedora 29 now, after installing a couple of conflicting packages, such as mpich and openmpi, things like module load mpich work well.

alfC gravatar imagealfC ( 2019-02-15 18:18:03 -0600 )edit
1

answered 2019-02-15 09:37:14 -0600

davidsch gravatar image

As module is not an executable, but implemented as functions, after installing with

sudo dnf install environment-modules

it also needs to be loaded. Thus normally happens during init, so if you just installed it, you can load it e.g. for bash with:

source /usr/share/Modules/init/bash
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-12-11 21:42:43 -0600

Seen: 1,404 times

Last updated: Dec 12 '14