Ask Your Question
2

Mouse problems fedora 21

asked 2014-12-10 18:55:41 -0500

turcottev gravatar image

I have installed fedora 21. The mouse cursor is doing very strange paterns on the screen. 1) Mouse cursor doing strange mouvements over the screen even if I don't move the mouse. The cursor jump ramdomly anywhere 2) Sometimes a small box appear near the mouse cursor

edit retag flag offensive close merge delete

Comments

I also have very strange mouse problems, sometimes i have more than one cursor, sometimes there is a trace behind my cursor and my screen gets full with cursors moving around. I'm having difficulties to identify which one is real cursor. when i right click on desktop sometimes that menu never goes away.

gorkem gravatar imagegorkem ( 2014-12-11 14:51:30 -0500 )edit

i also have very strange mouse problems. i have a trace behind my cursor and every ghost cursor moves independently. i would really appreciate it if there is a fix.

gorkem gravatar imagegorkem ( 2014-12-11 14:54:47 -0500 )edit

I have the same problem. It seems the problem is with X window Server, But I could not find the reason and fix.

Pooria gravatar imagePooria ( 2014-12-12 06:38:18 -0500 )edit

Same problem here. My laptop has a secondary nvidia gpu and uses the optimus dual-gpu tech, I wonder if that has anything to do with it. Running the live image without install seem to work well, no mouse cursor flickering at all.

etiggy gravatar imageetiggy ( 2014-12-13 06:07:51 -0500 )edit

I can't see my previous comment so I'm unable to edit it, but just a quick update: the flickering came up even running the live image session shortly afterwards the post. I have rebooted the laptop with the nvidia gpu diabled, so far no mouse cursor problems.

etiggy gravatar imageetiggy ( 2014-12-13 06:57:19 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
2

answered 2014-12-28 13:28:03 -0500

ckara gravatar image

updated 2015-01-11 13:43:38 -0500

I had the same problem. I think the problem is with the second discrete nvidia gpu (nvidia optimus technology). I have the nvidia GeForce GT 520MX card. A known problem with these cards is having a VGA port as connected, when that is not the case (type xrandron your terminal to check that there is a VGA-1-2 or VGA-1-1 connected). For the rest of this answer I assume we have VGA-1-2. You can change the commands accordingly in case of VGA-1-1. For more information about this check this freedesktop entry.

This page suggests to add video=VGA-2:d to the kernel command line in case xrandr gave VGA-1-2 as connected ( video=VGA-1:d in case of VGA-1-1). This solution didn't work for me. Nor just disabling the second VGA by the Settings GUI (the VGA continued to appear). Not even using xrandr --output VGA-1-2 --off. You can try these solutions first and check if they work for your case.

A workaround that worked for me was to add a conf file to /etc/X11/xorg.conf.d/ and just disable the VGA display with this code:

Section "Monitor"
    Identifier "VGA-1-2"
    Option "Ignore" "true"
    Option "Enable" "false"
EndSection

I am not an expert, and I think a more clever solution can be found because with this workaround the VGA port of the discrete card is disabled (if there is actual any), and I don't know if the VGA port of my laptop connects with the integrated card or the discrete card (I don't care, because I don't use it :). Until that time this workaround should suffice. I can't upload my .conf file because I don't have enough karma (this is my first answer).

Also installing the nvidia proprietary drivers (through rpmfusion or by installing bumblebee or use the nvidia official site) solves this problem.

edit flag offensive delete link more

Comments

Nice, works for me VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 540M] [10de:0df4] (rev a1)

LuisFer gravatar imageLuisFer ( 2014-12-30 13:23:13 -0500 )edit

Installation instructions for the proprietary driver can be found in the following guide from rpmfusion: http://rpmfusion.org/Howto/nVidia

erik gravatar imageerik ( 2016-02-29 16:28:07 -0500 )edit
0

answered 2016-09-23 08:39:59 -0500

atma gravatar image

settings>displays>secondary display>disable. This solution worked.

edit flag offensive delete link more
0

answered 2015-01-21 15:07:56 -0500

Geezus gravatar image

I had the same problem with my laptop that has an nvidia discrete card also. Found the solution here.

http://forums.fedoraforum.org/showthread.php?t=302008

edit flag offensive delete link more
0

answered 2016-12-14 18:37:14 -0500

mgeorgevich1959 gravatar image

I don't understand why you would disable the second display. I am having the issue with the mouse pointer but I need to use the second display, just disabling it doesn't help me at all.

edit flag offensive delete link more
0

answered 2015-04-01 00:44:32 -0500

http://forums.fedoraforum.org/showthr...

answer here is the best and easiest solution i.e just disable the 2nd screen. go to settings>displays>secondary display>disable.

edit flag offensive delete link more

Comments

This solution still works. :)

atma gravatar imageatma ( 2016-09-23 08:41:06 -0500 )edit

Question Tools

3 followers

Stats

Asked: 2014-12-10 18:55:41 -0500

Seen: 5,995 times

Last updated: Apr 01 '15