Ask Your Question
0

Remove xfce

asked 2014-11-15 19:22:21 -0600

slick1537 gravatar image

Hi all I'm running fedora 20. I originally installed it as the xfce spin but now I've decided I like kde better and would like to remove xfce. I tried yum group remove @xfce but I got this...

Running transaction check
ERROR with transaction check vs depsolve:
desktop-backgrounds-compat is needed by (installed) lightdm-gtk-1.6.1-3.fc20.x86_64
You could try running: rpm -Va --nofiles --nodigest

Not really sure what that means but I don't want to break anything.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-25 16:43:35 -0600

deadrat gravatar image

Your system is still using lightdm as a display manager. If you have installed the full KDE, it must also have installed the KDM. So please change your display manager to KDM, reboot your system and then remove XFCE. It should work that way.

If you prefer lightdm, perform above steps and remove XFCE, then install lightdm and then change your display manager to lightdm.

You may also consider using other display managers like GDM.

edit flag offensive delete link more
0

answered 2014-11-15 20:25:42 -0600

sideburns gravatar image

If you haven't installed KDE yet you're still using lightdm as your display manager. I think that your best bet is to install KDE, log out and back in (selecting KDE) and try again. You may need to tell systemd to use KDE's display manager instead of lightdm, but we'll worry about that if and when it comes up.

edit flag offensive delete link more

Comments

Yea I've been in KDE for a few days now I think the problem might have something to do with systemd like you mentioned. How can I do that?

slick1537 gravatar imageslick1537 ( 2014-11-16 04:35:54 -0600 )edit

I just went ahead and changed the display manager to KDE with systemctl enable --force kdm.service. I rebooted to confirm it worked and it did. However I still receive the same error when trying to remove the xfce group.

slick1537 gravatar imageslick1537 ( 2014-11-16 05:09:06 -0600 )edit
1

I was able to make it work by first changing the display manager to kdm, then removing lightdm, them finally removing the xfce group.

slick1537 gravatar imageslick1537 ( 2014-11-16 05:17:00 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-11-15 19:22:21 -0600

Seen: 1,085 times

Last updated: Nov 25 '14