Ask Your Question
0

Created a Xen bridge on F20 and networking will not start on boot...

asked 2014-11-03 14:33:22 -0600

GobleSt gravatar image

After troubleshooting I found that I need to run the following commands manually to start networking:

  • sudo ifup em1
  • sudo ifup xenbr0
  • sudo route add default gw 192.168.0.1

I want to have these run on boot so that I do not have to run them manually. How do I create a script for this?

/etc/sysconfig/network-scripts/ifcfg-em1:

TYPE="Ethernet"
BOOTPROTO=none
DEVICE="em1"
ONBOOT="yes"
HWADDR=A0:D3:C1:05:20:A0
BRIDGE=xenbr0
DELAY=0
NM_CONTROLLED=no

/etc/sysconfig/network-scripts/ifcfg-xenbr0:

DEVICE=xenbr0
TYPE=Bridge
BOOTPRO=none
IPADDR0=192.168.0.10
PREFIX0=16
GATEWAY0=192.168.0.1
DNS1=192.168.0.1
ONBOOT=yes
DELAY=0
NM_CONTROLLED=no
BRIDGE_STP=on

uname -a

Linux Sandbox 3.16.6-203.fc20.x86_64 #1 SMP Sat Oct 25 12:44:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
edit retag flag offensive close merge delete

Comments

Try BOOTPROTO=static instead of BOOTPRO=none in ifcfg-zenbr0

randomuser gravatar imagerandomuser ( 2014-11-03 16:30:39 -0600 )edit

I do believe that was one of the things I attempted but will try again......just tried...does not fix the issue.

GobleSt gravatar imageGobleSt ( 2014-11-04 13:50:13 -0600 )edit

@GobleSt - You shouldn't have changed it back if you tried BOOTPROTO before. BOOTPRO is gibberish.

randomuser gravatar imagerandomuser ( 2014-11-05 01:33:01 -0600 )edit

doh! I just tried "static" did not even catch the syntax error....!!! ...but alas, I tried again and still no go. Here is my CURRENT /etc/sysconfig/network-scripts/ifcfg-xenbr0:

DEVICE="xenbr0"
TYPE="Bridge"
BOOTPROTO=static
IPADDR0=192.168.0.10
PREFIX0=16
GATEWAY0=192.168.0.1
DNS1=192.168.0.1
ONBOOT=yes
DELAY=0
NM_CONTROLLED=no
BRIDGE_STP=on
GobleSt gravatar imageGobleSt ( 2014-11-06 05:44:48 -0600 )edit

Try removing the quotes from Type=. You'd think it would work, but shrug - my bridges don't have that, and they work :)

randomuser gravatar imagerandomuser ( 2014-11-06 14:43:43 -0600 )edit

I added them hoping to fix because I noticed them in my other file. They make no difference. I will try removing from both but do not expect a change.

GobleSt gravatar imageGobleSt ( 2014-11-13 06:10:27 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-24 06:18:31 -0600

GobleSt gravatar image

The issue appears to be fixed by allowing network manager to handle it...

/etc/sysconfig/network-scripts/ifcfg-em1:

TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
NAME="em1"
UUID="5dfe2212-e3e4-485a-8290-6f6ab094080d"
ONBOOT="yes"
HWADDR="A0:D3:C1:05:20:A0"
PEERDNS="yes"
PEERROUTES="yes"
BRIDGE="xenbr0"
NM_CONTROLLED="yes"
DELAY="0"

/etc/sysconfig/network-scripts/ifcfg-xenbr0:

DEVICE="xenbr0"
TYPE="Bridge"
BOOTPROTO="none"
IPADDR="192.168.0.10"
NETMASK="255.255.0.0"
GATEWAY="192.168.0.1"
DNS1="192.168.0.1"
ONBOOT="yes"
NM_CONTROLLED="yes"
BRIDGE_STP="on

"

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-11-03 14:33:22 -0600

Seen: 383 times

Last updated: Nov 24 '14