Ask Your Question
0

Acer Aspire 5951G shuts himself down on gaming/high usage

asked 2014-11-02 07:15:29 -0600

merb gravatar image

updated 2014-11-02 09:01:48 -0600

Hello, currently I have a Acer Aspire 5951G with Fedora 20 installed. Currently when I start a game or have some usages with my nvidia card the computer shuts down after a while ~10 minutes. Currently on normal usage it works flawlessly.

I'm still not sure if this is a problem with nvidia or the cpu itself.

Currently sensors shows a Heat of 95°C just before the shutdown (which is really high), under normal load I have barely 60°C

Also I have a : Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz

While cpupower says:

analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 0.97 ms.
hardware limits: 800 MHz - 2.90 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 800 MHz and 2.90 GHz.
                The governor "powersave" may decide which speed to use
                within this range.
current CPU frequency is 1.89 GHz (asserted by call to hardware).
boost state support:
  Supported: yes
  Active: yes
  2600 MHz max turbo 4 active cores
  2600 MHz max turbo 3 active cores
  2800 MHz max turbo 2 active cores
  2900 MHz max turbo 1 active cores

Which looks somehow a little bit broken. I mean the CPU limit is 2 GHz while the governer can speed up to 2.90 GHz Also the current CPU frequency somehow goes over 2 GHz even after limiting it with cpupower

Edit1: Oh and I also tried another CPU Driver (acpi-cpufreq) which has the correct cpupower information, but it won't work, too. it still shuts the computer down, but somehow it takes a little longer. Oh and there is no Kernel oops or any other error in the journal. And I think that is caused since the Laptop shuts itself down not the Software on top of it. Also if I sometimes try to start him he will refuse to start again until I wait some minutes (this looks common to overheating issues)

Also I've installed Windows before I installed fedora to update the BIOS rev. Since I had the same issues with ubuntu before. (also on ubuntu i had some luck with thermald)

EDIT2:

Had some luck with thermald on Fedora, but after an hour or more the computer still shuts down.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-11-02 09:14:22 -0600

My laptop Thinkpad T420i shuts down from time to time. Speaking from hours of Googling and personal experience there is little you can do. Some systems aren't designed to handle as heavy load as gaming. You can still try various things to keep your temperature in reasonable range and avoid making it reach critical temperature limit.

  • Keep system vents clean.
  • Use a laptop cooler.
  • Stop other programs when playing games.
  • use a lightweight DE when gaming.
  • Make sure your fans are working fine. I use thinkfan to modulate speed at various temperature.
  • Play games at lower settings.
  • Nvidia graphic drivers are know to perform better than open souce ones. Do remember propritary drivers aren't supported on Fedora.

Hope this helps.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-11-02 07:15:29 -0600

Seen: 380 times

Last updated: Nov 02 '14