Ask Your Question
0

why fedora 20 64 bit telnet connections limit 65 ?

asked 2014-10-25 04:52:44 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hello Sir,

i installed fedora 20 64 bit in ibm server but telnet server is working fine but telnet is limiting to 65 users.

i edited /etc/xinetd.conf instances to 550

againg coming same 65 connections please advise how to change and where to change to increase telnet instances ?

Regards venkateswarlu k sys admin

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-10-26 22:08:48 -0600

On Fedora, telnetd is a socket activated service, controlled by /usr/lib/systemd/system/telnetd.socket and /usr/lib/systemd/system/telnet@.service. Each connection to the telnet socket spawns an instance of the telnet service. Any settings made to the matching file in /etc/systemd/system will override the settings in /usr/lib/systemd/system, so make your changes there by copying the telnetd.socket file then editing.

man systemd.socket will help you make the required changes; you'll find this section especially relevant:

MaxConnections=
           The maximum number of connections to simultaneously run services instances
           for, when Accept=true is set. If more concurrent connections are coming in,
           they will be refused until at least one existing connection is terminated.
           This setting has no effect on sockets configured with Accept=false or datagram
           sockets. Defaults to 64.
edit flag offensive delete link more

Comments

hi Accept=true also not wokrking any idea ?

venkateswarlu gravatar imagevenkateswarlu ( 2014-10-27 03:56:28 -0600 )edit

@venkateswarlu Please use the comment field for comments, and leave the answer section for answers. I moved this one.

So, you missed the crucial option here. It Accept=True is not set, all connections will be rejected; presumably you knew this since you have telnetd working already :) The option that pertains to you is MaxConnections=

/etc/xinetd.conf is not pertinent here, Fedora does not use xinetd for telnet.

randomuser gravatar imagerandomuser ( 2014-10-27 16:25:25 -0600 )edit

Thank you, it is working... before also i tried but system not rebooted( i think it is /etc/systemd/system/)

venkateswarlu gravatar imagevenkateswarlu ( 2014-10-28 01:10:56 -0600 )edit

Question Tools

Stats

Asked: 2014-10-25 04:52:44 -0600

Seen: 517 times

Last updated: Oct 27 '14