Ask Your Question
0

Unable to load nvidia module

asked 2014-10-17 16:50:04 -0600

SaeedMasoumi gravatar image

updated 2014-10-17 22:01:58 -0600

mether gravatar image

I try to install nvidia drivers in fedora from this link

I only try this yum update kernel* selinux-policy* after that i reboot my fedora but i'm unable to start gnome (it hangs on while booting) i also try to disabled selinux but nothing happen and when i enter as rescue mode i found that i have none of these packages akmod-nvidia xorg-x11-drv-nvidia-libs kernel-devel acpid and this is the output when i excute startx in rescue mode as a root

[  1397.581] 
X.Org X Server 1.14.4
Release Date: 2013-10-31
[  1397.581] X Protocol Version 11, Revision 0
[  1397.582] Build Operating System:  3.14.3-200.fc20.x86_64 
[  1397.582] Current Operating System: Linux saeedhost 3.11.10-301.fc20.x86_64 #1 SMP Thu Dec 5 14:01:17 UTC 2013 x86_64
[  1397.582] Kernel command line: BOOT_IMAGE=/vmlinuz-0-rescue-27528b4024bf4f5c8eeadbb3daee4d22 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap nomodeset rd.lvm.lv=fedora/root vconsole.font=latarcyrheb-sun16 rhgb quiet 3
[  1397.582] Build Date: 27 June 2014  01:35:28AM
[  1397.583] Build ID: xorg-x11-server 1.14.4-11.fc20 
[  1397.583] Current version of pixman: 0.30.0
[  1397.583]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  1397.583] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1397.584] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 18 00:44:06 2014
[  1397.618] (==) Using config file: "/etc/X11/xorg.conf"
[  1397.618] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  1397.618] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1397.689] (==) ServerLayout "Layout0"
[  1397.689] (**) |-->Screen "Screen0" (0)
[  1397.689] (**) |   |-->Monitor "Monitor0"
[  1397.689] (**) |   |-->Device "Device0"
[  1397.689] (**) |-->Input Device "Keyboard0"
[  1397.689] (**) |-->Input Device "Mouse0"
[  1397.689] (==) Automatically adding devices
[  1397.689] (==) Automatically enabling devices
[  1397.689] (==) Automatically adding GPU devices
[  1397.728] (**) FontPath set to:
    /usr/share/fonts/default/Type1,
    catalogue:/etc/X11/fontpath.d,
    built-ins
[  1397.728] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  1397.728] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1397.728] (WW) Disabling Keyboard0
[  1397.728] (WW) Disabling Mouse0
[  1397.728] (II) Loader magic: 0x80dd00
[  1397.728] (II) Module ABI versions:
[  1397.728]    X.Org ANSI C Emulation: 0.4
[  1397.728]    X.Org Video Driver: 14.1
[  1397.728]    X.Org XInput driver : 19.2
[  1397.728]    X.Org Server Extension : 7.0
[  1397.730] (--) PCI:*(0:0:2:0) 8086:0166:1025:064b rev 9, Mem @ 0xb3000000/4194304, 0xc0000000/268435456, I/O @ 0x00003000/64, BIOS @ 0x????????/131072
[  1397.730] (--) PCI: (0:1:0:0) 10de:1140:1025:0691 rev 161, Mem @ 0xb2000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00002000/128, BIOS @ 0x????????/65536
[  1397.730] Initializing built-in extension Generic Event Extension
[  1397.730] Initializing built-in extension SHAPE
[  1397.730] Initializing built-in extension MIT-SHM
[  1397.730] Initializing built-in extension XInputExtension
[  1397.730 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-17 18:32:43 -0600

sideburns gravatar image

You might try this set of instructions instead: http://forums.fedoraforum.org/showthread.php?t=204752 as they may have things the one you're using is missing. And, if you need to get rid of the proprietary drivers to get into X, boot to text mode and run this command as root:

yum remove \*nvidia\*

Once you've done that, you can reboot into a GUI using the nouveau drivers. Don't worry about the versions listed in the thread's title; the instructions are still current, and include a section that tells you how to tell if your card is supported and if so, which version of the drivers you need.

BTW, you might consider joining the fedora forum while you're there because it's a good source for help, just as ask.fedora is. Good luck, and let us know how things go.

edit flag offensive delete link more

Comments

Thanks, but it said there is no nvidia packages. is there another way? for example change xorg configuration to use i915(intel graphic driver)

SaeedMasoumi gravatar imageSaeedMasoumi ( 2014-10-17 23:50:14 -0600 )edit

Are you sure that you used the backslash as I did? I use the drivers from rpmfusion and using yum list installed \*nvidia\* gives me a complete list of those installed.

sideburns gravatar imagesideburns ( 2014-10-18 03:17:03 -0600 )edit

Yes I think all my nvidia packages have been removed

SaeedMasoumi gravatar imageSaeedMasoumi ( 2014-10-18 05:03:48 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-10-17 16:50:04 -0600

Seen: 494 times

Last updated: Oct 17 '14