Why is Firefox not finding Flash Player Plugin on Centos

asked 2014-09-26 11:48:19 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

In our production environment we are installing a Web-based product. The Operating System is Centos 6.5. For this product, we have installed Firefox-33 and Flash Player 11.2.202.406-release.x86_64. The problem is that Firefox starts, but it does not detect Flash Player Plugin.

The following error message is reported when we run Firefox:

1411663263429 addons.manager ERROR Exception calling provider startup: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [mozIGeckoMediaPluginService.addPluginDirectory]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource://gre/modules/addons/OpenH264Provider.jsm :: OpenH264Provider.startup :: line 271" data: no] Stack trace: OpenH264Provider.startup()@resource://gre/modules/addons/OpenH264Provider.jsm:271 < AMI_callProviders()@resource://gre/modules/AddonManager.jsm:875 < AMI_startup()@resource://gre/modules/AddonManager.jsm:750 < AMP_startup()@resource://gre/modules/AddonManager.jsm:2322 < AMC_observe()@resource://gre/components/addonManager.js:55 <

Questions are:

  1. Why is Firefox not detecting or connecting to Flash Player Plugin?
  2. Is Gecko Media Plugin not functioning, or not able to detect Flash Player?
  3. What steps should we take so that Firefox can detect the Flash Player Plugin ?

We would really appreciate any help in ths regard. In case this is not the right (sub)-forum, please advise where we should post this question.

edit retag flag offensive close merge delete

Comments

not sure if this reference can help but check this

pnemade gravatar imagepnemade ( 2014-09-27 03:16:45 -0500 )edit

It looks from that output that it's not the flash plugin module that cannot be found, but a subcomponent, OpenH264Provider

It might be you need additional codecs - although I've never seen this before. You could try installing the rpmfusion repository and looking for an H264 codec, probably from one of the GStreamer/Non-free packages.

I can't be of much more help, this is a Fedora board, and while CentOS is very similar, it's not identical - and multimedia is one of the biggest differences.

cobra gravatar imagecobra ( 2014-09-27 04:12:40 -0500 )edit

you probably need to install the bad and ugly packages of Gstreamer. Its not a flash issue.
If this issue still persists try to reinstall Firefox

Also if you're using the extracted version of Firefox downloaded from the website, you'll have to put the "libflashplayer.so" from the tar package of Adobe Flash at - /home/username/.mozilla/plugins/libflashplayer.so

REMEMBER TO UPDATE IT OWN YOUR OWN - if not installed via repos

bull500 gravatar imagebull500 ( 2014-09-27 05:56:15 -0500 )edit

Where did you install flash player plugin? Can you run ldd on its libflashplayer.so (e.g. ldd /usr/lib/mozilla/plugins/libflashplayer.so).

hedayat gravatar imagehedayat ( 2014-09-28 06:00:42 -0500 )edit