Ask Your Question
1

Getting Error while installing Google earth in fedora 20

asked 2014-09-18 01:43:30 -0600

Guru gravatar image

Iam trying to Install Google earth In fedora 20 ..But it can't install. getting error while running this script sh GoogleEarthLinux.bin .. Error is 1) (setup.gtk2:11939): WARNING *: Invalid borders specified for theme pixmap: /usr/share/themes/Adwaita/gtk-2.0/Entry/entry-border-fill.png, borders don't fit within the image 2) (setup.gtk2:11939): GdkPixbuf-CRITICAL *: gdk_pixbuf_get_width: assertion 'GDK_IS_PIXBUF (pixbuf)' failed ..

Please help me

From Guru

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-09-18 02:49:39 -0600

pnemade gravatar image

You should install following rpm forcefully to get google earth working for you on Fedora 20

https://dl.google.com/dl/earth/client/current/google-earth-stable_current_x86_64.rpm

and install it as " sudo rpm -ivh google-earth-stable_current_x86_64.rpm --force"

I think that bin file is old. I see bin file showing its for version GoogleEarthLinuxPlus-6.0.3.2197-installer whereas rpm installs google-earth-stable-7.1.2.2041-0.x86_64

edit flag offensive delete link more

Comments

also note that above rpm is not following Fedora packaging guidelines and installs /usr/bin directory which is not good as its already owned by filesystem package. That is why we need to use --force to install this rpm.

pnemade gravatar imagepnemade ( 2014-09-18 02:53:25 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2014-09-18 01:43:30 -0600

Seen: 1,285 times

Last updated: Sep 18 '14