Ask Your Question
0

Package with older kernel

asked 2014-09-10 15:12:36 -0500

Trismegistos gravatar image

updated 2014-09-12 02:28:16 -0500

I would like to install ati catalyst driver which cooperate with kernel up to 3.11. Fedora is currently running kernel 3.15. I would like to avoid installing kernel from the sources and use some prepackaged version (best from some official repo). I'd also like to block fedora from updating kernel beyond version 3.11.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-09-29 04:58:13 -0500

baoboa gravatar image

you can get it from koji

http://koji.fedoraproject.org/koji/packageinfo?packageID=8

but be careful it could compromise ( security fix ) or break your system (compatibility ) to downgrade your kernel

edit flag offensive delete link more
0

answered 2014-09-11 11:15:47 -0500

Rajat gravatar image

To make permanent changes, edit the /etc/yum.conf file and following entries to it:

exclude=kernel*

edit flag offensive delete link more

Comments

It will exclude all kernel version and question where I get older kernel from still remains.

Trismegistos gravatar imageTrismegistos ( 2014-09-12 02:27:45 -0500 )edit

where kernel update needed its better to run kernel update.

SDas gravatar imageSDas ( 2014-09-13 07:08:42 -0500 )edit
0

answered 2014-09-29 04:49:56 -0500

Trismegistos gravatar image

I will answer my own question. There are two yum plugins that are useful here: yum-allowdowngrade and yum-versionlock.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-09-10 15:12:36 -0500

Seen: 189 times

Last updated: Sep 29 '14