Ask Your Question
1

how to fix "missing libp11-kit" error?

asked 2014-08-23 22:24:57 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

$ sudo yum check
Loaded plugins: langpacks
gcr-3.10.1-1.fc20.i686 has missing requires of libp11-kit.so.0
gnome-keyring-3.10.1-1.fc20.i686 has missing requires of libp11-kit.so.0
gnutls-3.1.25-1.fc20.i686 has missing requires of libp11-kit.so.0
Error: check all
$ locate libp11-kit
/usr/lib64/libp11-kit.so.0
/usr/lib64/libp11-kit.so.0.0.0
$ sudo yum install libp11-kit
Loaded plugins: langpacks
No package libp11-kit available.
Error: Nothing to do

Some weeks ago i installed libp11-kit 32bit for fedora20 on rpmfind.net to walkaround this problem, then uninstalled it due to incompatible to new kenrel, but now there is no compatible version for fedora on rpmfind.net what should i do now? (sorry for my english)

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2014-08-23 22:58:38 -0600

skytux gravatar image

I don't know why you use rpmfind.net if you have the own Fedora repositories. Please, try the following command:

$ sudo yum provides */libp11-kit.so.0

and you will find out that the name of the package you are looking for is p11-kit.

HTH,

Germán.

edit flag offensive delete link more

Comments

thank you skytux, this works!

tim110011 gravatar imagetim110011 ( 2014-08-23 23:22:33 -0600 )edit

You are welcome! Please mark the answer as correct if it solved your problem :)

skytux gravatar imageskytux ( 2014-08-23 23:42:52 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-08-23 22:24:57 -0600

Seen: 584 times

Last updated: Sep 30 '14