Ask Your Question
2

Why can't I change my display manager? (GDM to LightDM)

asked 2014-08-18 15:58:49 -0600

james1381 gravatar image

updated 2014-11-18 08:38:43 -0600

FranciscoD_ gravatar image

I am running Fedora 20. I believe the way to change display managers starting in Fedora 18 is

sudo systemctl --force disable gdm.service

sudo systemctl --force enable lightdm.service

I have tried this, and no error has been returned, but on reboot I still have GDM. I have also installed system-switch-displaymanager and when I try using this it returns

Your default graphical display manager has successfully been switched.

But it hasn't! How do I change my display manager to LightDM (it is definitely installed)?

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
3

answered 2014-08-19 02:29:39 -0600

abadrinath gravatar image

updated 2014-11-25 03:05:26 -0600

Check if it is disabled:

$ sudo systemctl status {lightdm,gdm}.service

Next, mask gdm if it is "enabled":

$ sudo systemctl mask gdm.service

Or, if you don't even want gdm (or possibly GNOME), try

$ yum remove gdm

Warning: That might remove GNOME applications (Nautilus, stuff like that), so watch out for that.

Then, enable LightDM

$ sudo systemctl enable lightdm.service

HTH.

edit flag offensive delete link more

Comments

What is it?

abadrinath gravatar imageabadrinath ( 2014-11-18 00:02:34 -0600 )edit

yum remove gdm will probably want to take other gnome stuff with it. Be careful when you run it.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-11-18 08:38:27 -0600 )edit

True dat. I added a warning. Thanks :).

abadrinath gravatar imageabadrinath ( 2014-11-25 03:03:33 -0600 )edit
1

answered 2014-11-21 14:45:47 -0600

passthejoe gravatar image

The man page for system-switch-displaymanager doesn't mention lightdm, but I tried it anyway.

If you give the argument:

$ system-switch-displaymanager lightdm

First you get the same error output as when you use systemctl:

Failed to issue method call: Operation not supported

Then you get a line of output (can't remember it exactly) from system-switch-displaymanager that says the operation was a success.

However, when I reboot, I have NO display manager. I log in and am at a bash prompt. So I then used system-switch-displaymanager to switch back to GDM:

$ system-switch-displaymanager gdm

There is still no way to successfully switch from GDM to LightDM.

edit flag offensive delete link more
1

answered 2015-01-12 21:05:14 -0600

dchen gravatar image

I often change DM with following step:

  1. Enter console mode by press Ctrl-Alt-F3 (F2~F8 is also good), and login. Do NOT try to change display manager in GUI, as the behavior is unpredictable.
  2. sudo systemctl disable gdm
  3. sudo systemctl enable lightdm
  4. Stop gdm with sudo systemctl stop gdm
  5. Start lightdm with sudo systemctl start lightdm

That's it.

edit flag offensive delete link more

Comments

This worked like a charm. I used it to switch from kdm to sddm after a fedup based upgrade from F20 to F21.

Thanks !

gjanssens gravatar imagegjanssens ( 2015-01-21 14:25:31 -0600 )edit

thanks pal

christianbueno gravatar imagechristianbueno ( 2018-07-12 13:38:06 -0600 )edit
0

answered 2014-11-17 12:16:21 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I just successfully switched my display manager from LightDM to GDM with advice from this Fedora Users mailing list post.

First of all, make sure the GDM manager you wish to use is installed on your system.

I started with an Xfce system, and the Xfce spin uses LightDM. When I later installed GNOME, it brought GDM along with it.

But if you want to switch to GDM without GNOME, install it:

$ sudo yum install gdm

Then you switch one off and the other on:

$ sudo systemctl disable lightdm.service
$ sudo systemctl enable gdm.service

Then reboot your system, and the new display manager will come up.

The problem is going back.

I can sucessfully do this:

$ sudo systemctl disable gdm.service

But this command doesn't work:

$ sudo systemctl enable lightdm.service

I get this output in the terminal:

Failed to issue method call: Operation not supported

Any ideas?

edit flag offensive delete link more
0

answered 2014-11-18 08:37:30 -0600

FranciscoD_ gravatar image

I never tinkered with systemctl. I simply used the https://apps.fedoraproject.org/packages/system-switch-displaymanager package and it worked just fine. Give it a go?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-08-18 15:58:49 -0600

Seen: 59,759 times

Last updated: Jan 12 '15