Ask Your Question
0

Enabling Alt+Shift for input source disables Alt+Ctrl+Shift+[Arrow] navigation for windows

asked 2014-08-17 09:55:38 -0600

Mohamed Kamal Kamaly gravatar image

updated 2015-03-28 10:31:02 -0600

When enabling Alt+Shift for input source. The Alt+Ctrl+Shift+[Arrow] shortcut used to move a window between workspaces doesn't work anymore.

Is there's something that should be done ?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2014-08-19 08:10:09 -0600

Mohamed Kamal Kamaly gravatar image

updated 2014-08-19 20:01:56 -0600

This applies to any distro using Gnome 3, not specific to Fedora

After searching with no luck, I have seen the configurations of one of my friends on his Ubuntu+Gnome 3 installation using dconf-editor.

Turns out, the problem was in using "Modifiers-only switch input source" in Gnome Tweaks Tool option which I think calls the following command

setxkbmap -option grp:alt_shift_toggle "us,ar"

and that conflicts with the gnome moving window between workspace shortcut

There are two ways to do that

in both ways, you need to open gnome-tweak-tool and disable "Modifiers-only switch input source" then

First way using gsetting

just run the following command

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Alt>Shift_L', '<Alt>Shift_R']"

Second way using dconf-editor

  1. install and open dconf-editor.

  2. Press Ctrl+F and write "switch-input-source" or navigate to org.gnome.desktop.wm.keybindings and look for the same key.

  3. Double click on the key and change it to

    ['<alt>Shift_L', '<alt>Shift_R']</alt></alt>

This means I will use the Alt+Left Shift and Alt+Right Shift to switch the language

This way, it will work nicely with the Alt+Ctrl+Shift+[Arrow] shortcut

Edit 1: add gsetting command

edit flag offensive delete link more

Comments

Looks interesting, I'll certainly check it!

hedayat gravatar imagehedayat ( 2014-08-19 13:00:00 -0600 )edit
0

answered 2015-01-14 02:48:35 -0600

ukl gravatar image

I hit the same problem on Debian without any configurations changed. There the default key-combo for Move window one workspace up changed to Shift + Super + Page Up. For moving between workspaces both Ctrl + Alt + Up and Super + Page Up works.

edit flag offensive delete link more
0

answered 2014-08-17 19:26:43 -0600

mohamed94 gravatar image

hi Go to Settings =>> Keyboard =>> Shortcuts =>> Typing and change to what you need

edit flag offensive delete link more

Comments

That's why I did, I changed "Switching to another layout" to "Alt+Shift" then the Alt+Ctrl+Shift+[Arrow] shortcut I use to move a window between a workspace doesn't work anymore.

Mohamed Kamal Kamaly gravatar imageMohamed Kamal Kamaly ( 2014-08-18 02:22:06 -0600 )edit
0

answered 2014-08-17 13:45:43 -0600

hedayat gravatar image

AFAIK, no. You should either use a different key combination for changing input source, or set a different key combination for moving windows.

edit flag offensive delete link more

Comments

I used to set the same combination on ubuntu before I try to fedora and both were working well with each other, I think there's something missing to be done but I don't know what is it.

Mohamed Kamal Kamaly gravatar imageMohamed Kamal Kamaly ( 2014-08-18 02:23:42 -0600 )edit

I don't know. maybe that works in Unity. Anyway, have you changed the default Gnome keys for moving windows? Notice that recent Gnome versions have decided to use "Super" key (win key) instead of "Alt" for most tasks, and the default key combination to move a window to above/bottom workspaces are "Shift+Super+PgUp" and "Shift+Super+PgDown". You can modify them to use Up/Down arrow keys instead of PgUp/PgDown.

Using Super instead of Alt would solve your problem. I don't know if you can use Alt.

hedayat gravatar imagehedayat ( 2014-08-18 04:32:41 -0600 )edit

it is allowed using Super and Alt , however I thought that maybe the problem, so I tried to change it throught dconf but I found out that it is configured to use both the shortcut. Open org.gnome.desktop.wm.keybindings" using dconf and look for keys move-to-workspace-*

Mohamed Kamal Kamaly gravatar imageMohamed Kamal Kamaly ( 2014-08-19 07:14:47 -0600 )edit

Sorry, I don't understand your point. As I said, using Alt+Shift+etc. is unlikely to work correctly in Gnome Shell as far as I know. If possible, it would need some special configuration. Anyway, personally I found using Super convenient enough so I've never tried to get Alt+Shift+etc working for shortcuts while Alt+Shift is being used for changing keyboard layouts.

hedayat gravatar imagehedayat ( 2014-08-19 07:42:14 -0600 )edit

I mean the default shortcut in gnome 3 for moving the window across workspaces for example upwards is both Shift+Super+PgUp and Alt+Shift+Ctrl+Up , but enabling Alt+Shift for the language change conflicts with the Alt+Shift+Ctrl+Up, however I found a work around, please check my answer above.

Mohamed Kamal Kamaly gravatar imageMohamed Kamal Kamaly ( 2014-08-19 08:18:07 -0600 )edit

Question Tools

Stats

Asked: 2014-08-17 09:55:38 -0600

Seen: 4,277 times

Last updated: Jan 14 '15