Ask Your Question
1

gnome-software installed applications list is empty

asked 2014-08-14 14:17:31 -0600

aws gravatar image

updated 2015-03-28 10:30:48 -0600

Hello, I have gnome 3.12 on fedora 20 and gnome-software-3.12.2-3.fc20.x86_64. When I type sudo yum [or dnf] -qa I receive a list of all installed applications, however gnome-software indicates that I have NO installed applications. I wanted to create "app-folders" and I read that the only way to do that is to use "gnome-software", [also why is there no commandline way to do that? Example --> edit desktop files categories or using gsettings? But I digress, that is a secondary question]. How do I make "gnome-software" show that I have ANY applications installed on my system? I have dozens of applications installed, including full "Gnome Desktop" and full "Mate and XFCE Desktop" and many commonly used programs. Gnome-software also never shows a need for any updates, even though there are frequently many as indicated on the commandline. All org.gnome.settings-daemon.updates keys have been left at the gnome installed defaults - unchanged. ie. frequency-get-updates 86400. This computer runs 24/7 with reboots only for kernel updates, so 24hours=86400seconds have long, long passed. Thank you. Anton Schenker.

edit retag flag offensive close merge delete

Comments

1

the problem is generate all metadata, you can't see all package because much developer doesn't want contribute, including a metadata to your source code...

davidva gravatar imagedavidva ( 2014-08-28 13:36:43 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-08-28 11:01:15 -0600

FranciscoD_ gravatar image

Try: pkcon refresh and see if that gets gnome-software to list your packages.

edit flag offensive delete link more
1

answered 2015-09-03 02:30:16 -0600

Abraham gravatar image

updated 2015-09-07 02:02:53 -0600

Go to /etc/yum.repos.d/ Edit fedora.repo and fedora-updates.repo Remove the # from all lines that start with #baseurl Insert a # at the beginning of all lines that begin with metalink

Now edit the /etc/hosts file and add the following lines at the bottom

80.239.156.215 mirrors.fedoraproject.org

213.129.242.84 mirrors.rpmfusion.org

As superuser run the following command

pkcon refresh

Now restart the system

edit flag offensive delete link more

Comments

disable mirror? What is this principle? Can you explain?

eexpss gravatar imageeexpss ( 2017-03-27 23:33:56 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2014-08-14 14:17:31 -0600

Seen: 1,930 times

Last updated: Sep 07 '15