Ask Your Question
11

Online Accounts - Gmail Password Unexpectedly Fails [closed]

asked 2014-08-01 08:25:10 -0600

torvum gravatar image

Ever since the most recent update (or perhaps the one before that), I've had trouble with my Fedora 20 "Online Accounts" feature, specifically as applied to my Gmail account.

So, here's the problem I'm having:

All of a sudden, I'm now periodically prompted by Fedora to enter my Gmail account password. When I do so, it tells me my password was typed incorrectly. Now, I'm 100% positive I'm typing it right. No problem, I'll just erase my Gmail account in the "Online Accounts" section of Settings, and start from scratch; surely that will fix my problem.

I erase my Gmail account, and begin to re-add the same account. The gmail log-in screen pops up, I type in my email and password, and it transfers me to the confirmation page—the one that asks you about whether you're ok with Fedora having access to all these different bits of info—at which point I confirm and yay, my account it setup and this time it's going to work for sure because I just logged into my gmail account using the "Online Accounts" feature so it just must work now, right? Nope.

Five seconds later the same password prompt pops up asking me to supply my Gmail password, after which it invariably tells me I've typed it wrong.

* Confused and frustrated *

Any help would be much appreciated!

N.B.: I'm not sure if this is important, but my password does include special characters, i.e. those that are found above the number keys.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2016-04-13 22:11:00.683884

Comments

An idea: try switching imap to pop or pop to imap servers!

abadrinath gravatar imageabadrinath ( 2014-08-01 20:55:41 -0600 )edit
5

I'm having the exact problem, Fedora 20 64bit, latest updates

ruturajv gravatar imageruturajv ( 2014-08-01 22:24:36 -0600 )edit

Are you using Two-Factor Authentication?

QuLogic gravatar imageQuLogic ( 2014-08-02 00:22:05 -0600 )edit

strangely its started working automatically !!! WTF ?!

ruturajv gravatar imageruturajv ( 2014-08-02 06:45:22 -0600 )edit

Well, I think the problem just comes back. I've pressed cancel more than a few times. More importantly, however, I don't see my google calendar events which leads me to believe it's not actually connecting to the service.

As for switching imap to pop or vice versa, I'm really not sure how to do that. I don't see any options in the "Online Accounts" section.

torvum gravatar imagetorvum ( 2014-08-02 17:46:59 -0600 )edit

13 Answers

Sort by » oldest newest most voted
4

answered 2014-08-05 10:28:14 -0600

torvum gravatar image

I've posted a bug here: https://bugzilla.gnome.org/show_bug.cgi?id=734298#c0

If you're having the same issue then do me a favour and comment on it saying as much.

edit flag offensive delete link more

Comments

I added a comment to your bug report because this happens to me also.

skytux gravatar imageskytux ( 2014-08-05 14:24:48 -0600 )edit
FranciscoD_ gravatar imageFranciscoD_ ( 2014-08-27 02:07:48 -0600 )edit
1

Ooh, goood call, FranciscoD_! That was it exactly. I backported that fix to 3.10.4 and it completely cleared up this problem. More info below in my answer, which I'm about to update...

FeRDNYC gravatar imageFeRDNYC ( 2014-08-27 11:30:56 -0600 )edit
4

answered 2014-08-27 00:34:00 -0600

FeRDNYC gravatar image

updated 2014-11-03 20:07:10 -0600

SOLVED! (At least for me...)

FranciscoD_ spotted Gnome bug #735311 related to authentication, and it turned out to be exactly the problem I was experiencing. Kudos to him for catching that.

Fedora have since released the necessary fix to fedora updates, starting with evolution-data-server-3.10.4-5.fc20.$ARCH, so anyone experiencing this problem should just update their system through the normal channels. I've taken down my builds, as they're no longer needed.

Previous Update

After discovering that e-d-s-3.12.5 (the F21 version which received that bugfix) won't build under F20, I backported the fix to F20's current e-d-s-3.10.4 — which wasn't hard, as the patch applied cleanly with a little bit of extra fuzz — and built myself a new evolution-data-server-3.10.4-4.

After installing the update and logging out/in, this issue completely cleared up. No more password prompts on Shell start, and my Gnome Calendar data is once again appearing in both the Shell titlebar calendar and in Evolution! (Don't forget to also reenable Calendar in Online Accounts, before logging out.)

I'll report this to the Gnome and Fedora folks and see if they can gin up new official builds, but in the meantime anyone's welcome to my fixes: [REMOVED]

Original Discussion

The issue is with Google Calendar, specifically.

I also am not using two-factor authentication, but I've been plagued by password-entry dialogs for at least a week or two. Earlier tonight I went through most of the same troubleshooting steps that torvum did, with the same lack of success.

(I even went one step further and ended up dbus-monitor-ing a restart of Gnome Shell, to see what I could see when the password entry dialog popped back up again — since I log in to a lot of services using my gmail email address, I was trying to determine more concretely just which of those many logins, with different passwords, the dialog might be asking for, since it wouldn't take my Google password. Some 65k lines of output later, that turned out to be singularly uninformative.)

However, you can convince yourself (as I did) that it's Calendar that's failing, with these steps:

  1. Start Evolution
  2. Get the password prompt again; cancel it
  3. Notice that you can read your Google mail, and see your Google contacts, with no trouble
  4. Attempt to view your Google calendar, and instead of seeing your scheduled events, note the failed-connection errors that appear along the bottom of the Evolution window.

Going into Online Accounts settings and switching off Calendar in the "Use For" section will stop the password-entry dialogs from pestering you; the rest of your Google account connectivity will function normally. (Well... I don't know about Chat as I don't use it, so mine's always switched off.)

edit flag offensive delete link more

Comments

Your Dropbox link results in a 404. However, I received evolution-data-server-3.10.4-4.fc20 as an official update today, but it still does not solve the problem. Turning on Calendar still results in the "Password Incorrect" error. Keeping Calendar turned off works normally as before.

saurav gravatar imagesaurav ( 2014-09-11 01:58:02 -0600 )edit

OK, it seems to be working now, but I installed the libgcal package; don't know if that has anything to do with it.

saurav gravatar imagesaurav ( 2014-09-14 06:21:28 -0600 )edit

Ugh, Dropbox was being squirrelly suddenly (I _did_ test these links, I swear!), thanks for the heads-up. (Which I only just saw, will have to check my notification email settings.) I moved the folder to the top level of my Dropbox space and generated a new link, answer updated just for completeness' sake. But I assume what solved it for you was that Fedora evolution-data-server-3.10.4-5.fc20 (one newer than the update you mention in your Sep 11 comment) has since been pushed containing the same fix, so my links aren't really needed anymore.

FeRDNYC gravatar imageFeRDNYC ( 2014-09-14 20:18:49 -0600 )edit

Yes, the Dropbox link is working now. And after reading your comment I checked and saw that, sure enough, evolution-data-server-3.10.4-5.f20 was made available recently. Anyway, all's well that ends well!

saurav gravatar imagesaurav ( 2014-09-19 18:10:58 -0600 )edit

where is this version of evolution for Fedora 20 ?

sergiomb gravatar imagesergiomb ( 2014-11-03 09:46:24 -0600 )edit
2

answered 2014-08-03 03:38:34 -0600

FranciscoD_ gravatar image

I'm on gnome 3.13 at the moment and periodically get asked for my Google password. The first time, irrespective of whether it's correct or not, it says that the password was wrong. The second time, it accepts it. It could be a bug. Please file one here - https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-online-accounts and upstream will take a look.

edit flag offensive delete link more

Comments

2

I'm on 3.10 and it never accepts it. I just have to hit cancel. I will, however, file a bug report.

torvum gravatar imagetorvum ( 2014-08-03 09:07:48 -0600 )edit

I have the same issue with google account in fedora 20. If it matters, I have enabled two step verification..

Even my windows account cannot connect to server. It says as unknown error.

deadrat gravatar imagedeadrat ( 2014-08-05 02:16:59 -0600 )edit

This sounds like the "other" bug, the one that isn't Calendar specific. The one I was experiencing (and at least torvum as well, I suspect, since literally every single symptom mentioned has been identical to my own observations) was indeed an instance of Gnome bug#735311, as you suggested in your comment above. The fix from that bug squashed it handily. (Many thanks for the pointer!) But I guess that's only one of the Google authentication bugS — plural — in Online Accounts...

FeRDNYC gravatar imageFeRDNYC ( 2014-08-27 13:53:14 -0600 )edit

Well, feel free to file bugs upstream. They're quite happy to fix them :)

FranciscoD_ gravatar imageFranciscoD_ ( 2014-08-27 16:37:47 -0600 )edit

GNOME 3.14.2 here, Fedora 21. Still ask for password, altrough not as offten as before, so at one point I thought it was fixed. But it is not fixed. Before (Fedora 20 and current CentOS7) it asked on login, and several more times later. Now (Fedora 21) it doesn't ask on login, but it asks at least once later, for no reason. Password is always rejected.

gnufreex gravatar imagegnufreex ( 2015-01-19 10:32:30 -0600 )edit
1

answered 2014-08-02 15:31:01 -0600

I can replicate this issue in standard Fedora 20 virtual machine, so I don't think it's got anything to do with your system's configuration (beyond being up to date and Fedora 20, that is).

If you choose "cancel" when prompted for credentials, does the problem persist? I was causing my machine to prompt me for credentials by rebooting (which succeeded in causing it to prompt every time) and I noticed that simply canceling the request allows me to continue to use Empathy and other services relying on this feature without issue.

edit flag offensive delete link more
1

answered 2014-09-14 15:36:52 -0600

mads gravatar image

The latest update from Fedora seems to have fixed the problem.

edit flag offensive delete link more
1

answered 2015-03-08 10:22:57 -0600

brevardandbrevard gravatar image

I had this issue on CentOS 7 - just installed and fully updated (over 300 updates!).

The fix was to first turn off the Calendar in the CentOS 7 -> Settings -> Online accounts.

This caused the calendar for the Google account to disappear in Evolution.

Then I added a new calendar directly in Evolution of type Google. Since I used two-factor authentication, I had to generate and App Password specifically for this in my Google -> Account Settings -> App Passwords.

I had been doing that before but the prompt would never accept that App Password.

When doing it this way, the App Password was accepted and I can access that Google account calendar in Evolution.

edit flag offensive delete link more

Comments

Seeing as the issue still happens in Gnome on Fedora 21, this is probably the best solution for the time being.

jflory7 gravatar imagejflory7 ( 2015-03-09 15:43:11 -0600 )edit
1

answered 2014-08-10 16:17:38 -0600

oldwismn gravatar image

I am on Fedora 20 x64 with the latest updates and GNOME 3.10. My password was never accepted; I had to hit cancel. As a workaround, I deleted my Google online account in GNOME. Then added my Google email account in Evolution. Evolution provided an option for me to include my contacts and calendar. Now my email, contacts, and calendar all work fine and I am not asked for my password.

edit flag offensive delete link more
0

answered 2015-01-13 06:26:33 -0600

edit flag offensive delete link more

Comments

Trying this. Will see if it makes the same popup in F21 go away as well!

jflory7 gravatar imagejflory7 ( 2015-01-19 14:31:21 -0600 )edit
0

answered 2015-08-13 09:17:06 -0600

After this happened to me, I get an email from gamil:

Sign-in attempt prevented. Someone just tried to sign in to your Google Account xxx.gmail.com from an app that doesn't meet modern security standards...

I installed Linux Fedora 22 yesterday.

Suggestions?

edit flag offensive delete link more
0

answered 2014-08-05 13:37:53 -0600

Tiger gravatar image

go to google application security link:- https://security.google.com/settings/security/apppasswords

and genrate your app password and enjoy...

edit flag offensive delete link more

Comments

I had tried that.. That doesn't work either.

deadrat gravatar imagedeadrat ( 2014-08-05 15:07:31 -0600 )edit
1

what error you get.....??

Tiger gravatar imageTiger ( 2014-08-07 00:31:37 -0600 )edit

sorry about that, @hello. It was a mistake.

@Tiger, When I generate app password and use it, it simply says "incorrect password", same way like what it does for original password.

I cannot even upload a screenshot.. it says I do not have enough karma.. (lol)

deadrat gravatar imagedeadrat ( 2014-08-08 01:52:27 -0600 )edit
deadrat gravatar imagedeadrat ( 2014-08-21 18:41:08 -0600 )edit

it works !!!! , I give you 2 or 3 votes if I can, I have two phases auth , and I used autogenerated a app password to login my imap account on evolution

sergiomb gravatar imagesergiomb ( 2014-11-03 09:52:18 -0600 )edit

Question Tools

10 followers

Stats

Asked: 2014-08-01 08:25:10 -0600

Seen: 17,771 times

Last updated: Mar 08 '15