Ask Your Question
0

My mouse moves too fast

asked 2014-07-28 12:09:40 -0500

rafaelluik gravatar image

I bought a simple new USB optical mouse to replace a broken one, a Multilaser Mo180 - 800 dpi.
I turned off my PC to unplug my old PS/2 optical mouse (that had the perfect speed), then I plugged the new mouse and started my computer.

The big problem is that it's flying! It's way too fast when I move it. I also noticed that in Windows 8.1.1 but I could set it to go slower in the mouse preferences at the Control Panel.

When I booted to Fedora 20, same problem. Ok, now here I go to GNOME Control Center...
Issue #1: The setting slider bar was already at its lowest, but the mouse was still really fast. After scratching my head a little I moved the slider to the right (increasing the speed), then moved it all the way back to the left (lowering). It became a little better but:
Issue #2: It's just a little better, but it's still too speedy! It's unusable because I keep missing the right spot I want to click (like close buttons, toolbar buttons, menus - it's lacking accuracy completely, even though these elements aren't really tiny at all in my display/resolution) and made me think of buying another mouse... But this just isn't a realistic solution.

What can I do?
First, issue #1 looks like a bug.
Issue #2 (the point of this question) looks like another bug I should file against the kernel or something else?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

You might try with Xorg settings to see if it can help you. There are a number of options related to pointer acceleration/deceleration in man xorg.conf, man xinput and man xset.

hedayat gravatar imagehedayat ( 2014-07-28 14:33:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-01 21:44:16 -0500

abadrinath gravatar image

updated 2014-08-02 20:58:02 -0500

Honestly, that looks like a kernel bug or an Xorg bug to me. Try filing a bug report at the Red Hat bugzilla, and wait for their response. Most likely, it is a bug, but if it is just a one time issue, try @hedayat's answer. Here is the place to file any bugs:

www.bugzilla.redhat.com

Create an account and file a new bug report. Before you do that though, make sure it is not a duplicate through google. I would suggest you search "site:bugzilla.redhat.com mouse + fast" on Google. That will notify you of any already available bugs and possible workarounds or solutions. As a last resort, also try "mouse too fast + Linux" on Google as well. This will include answers for different distributions as well. Keep in mind, this might not work for Fedora and may mess up some parts of the system. Last, take a video of the fast mouse, and maybe give them kernel version, Xorg version, etc in the bug report for more details.

EDIT: Thanks for the update, @sideburns.

edit flag offensive delete link more

Comments

Before opening a new bug report (or "bugzilla" as it's usually called) do a search, looking for all open bugs that use the word "mouse." You might find that this has already been reported, and even not, you may well end up opening your report against something that looks closer to the culprit. Don't worry about guessing wrong, because whoever it gets assigned to can always change it to point at the right component if needed.

sideburns gravatar imagesideburns ( 2014-08-02 14:43:37 -0500 )edit

Forgot that part @sideburns. Thanks for reminding me. Feel free to comment on any other stupid mistakes :).

abadrinath gravatar imageabadrinath ( 2014-08-02 20:52:49 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-07-28 12:09:40 -0500

Seen: 867 times

Last updated: Aug 02 '14