Ask Your Question
0

FTP server setup/Fedora 20

asked 2014-07-28 02:58:50 -0600

Anya gravatar image

updated 2014-07-28 08:46:37 -0600

mether gravatar image

Hi,

I am trying to install FTP server with following instructions here https://ask.fedoraproject.org/en/question/9324/fedora-16-vsftpd-config/ When I come to the part of accessing FTP (#Ftp server1) I get a mistake "ftp:server1:Name or service not known" I have Fedora 20 installed in Virtual box.Could that be a problem? Please,please help

edit retag flag offensive close merge delete

Comments

Hello: server1 is just representing the hostname of the ftp server you want to reach. It needs to be defined on ftp client side either in /etc/hosts or as a DNS entry.

So you need to adapt your command-line to actual hostname or IP-address of ftp server.

In itself, being installed on a VM is not a problem. However, If you use a NAT'ed network interface on your VM, you'll need to add some port forwarding.

You may edit your post to give more detail on your configuration (client side notably).

tonioc gravatar imagetonioc ( 2014-07-28 06:57:19 -0600 )edit

Thanks, I missed it with /etc/hosts Could I just ask, what exactly should i write there? There is already this written, should I erase it all? 127.0.0.1 localhost.localdomain localhost : : 1 localhost6.localdomain6 localhost6 I am sorry if that is a very stupid question, I am totally new with that

Anya gravatar imageAnya ( 2014-07-29 04:47:48 -0600 )edit

@Anya, I'm affraid you are mixing several things. Please provide more information on where your ftp client is running. From what I understand the server is in a virtual-box VM, but you also did not mention how network is configured on this.

tonioc gravatar imagetonioc ( 2014-07-29 06:46:36 -0600 )edit

@Anya, don't even think about removing what's currently in /etc/hosts if you want your computer to connect to any network. Everything that's in there needs to be there. If you know the name and IP address of the server you want to reach, you can add that to the file so that any DNS issues won't block access. However, if the server's IP address changes, you'll need to correct the entry.

sideburns gravatar imagesideburns ( 2014-07-29 20:46:33 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-07-28 17:14:42 -0600

sergiomb gravatar image

updated 2014-07-28 17:47:37 -0600

could be a firewalld that blocks the port , try :

 firewall-cmd --add-service=ftp

if it work configure your firewall to accept incoming FTP permanently:

firewall-cmd --add-service=ftp --permanent
edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-07-28 02:58:50 -0600

Seen: 1,001 times

Last updated: Jul 28 '14