Ask Your Question
1

Gnome doesn't automatically start

asked 2014-07-25 17:33:48 -0600

P gravatar image

updated 2014-09-29 00:00:26 -0600

mether gravatar image

I had a Fedora 20 minimal installation, I installed Gnome using yum, but it still boots to commandline and I have to do startx to get the desktop.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-25 17:52:20 -0600

NickTux gravatar image

Have you enabled the gdm ? (Gnome Display Manager)

To check the status

systemctl status gdm.service

if returns, disabled, you should enabled it with

sudo systemctl enable gdm.service

Then, reboot the system and it should be ok.

edit flag offensive delete link more

Comments

It's says it's active. Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled)

P gravatar imageP ( 2014-07-25 22:32:23 -0600 )edit

Then, check the cat /var/log/Xorg.0.log and search for any error messages. If you want to post this file, please use fpaste and give here the link. Also the output of journalctl -b -p err might help. Thanks.

NickTux gravatar imageNickTux ( 2014-07-26 04:59:57 -0600 )edit

Xorg.0.log : http://fpaste.org/121074 Last 1000 lines of the journalctl : http://fpaste.org/121066

P gravatar imageP ( 2014-07-26 13:32:39 -0600 )edit

As I see it, especially from the journalctl errors log, this should be a bug. I would stronly recommend to open a bug report immediately and post there the error log. As a workaround, you can try to boot from an older kernel version (through grub menu). Of course you could try to install the closed source nvidia drivers, but I won't recommend this (closed source - you know).

NickTux gravatar imageNickTux ( 2014-07-26 14:39:16 -0600 )edit

The point is, Gnome just doesn't start automatically, I can get it manually by doing a startx. I'll try the nVidia drivers, but I don't quite understand how can that relate to the problem at all.

P gravatar imageP ( 2014-07-26 17:34:25 -0600 )edit
0

answered 2014-07-30 07:27:54 -0600

FranciscoD_ gravatar image

Have you set the default boot target to graphical.target?

http://fedoraproject.org/wiki/SysVinit_to_Systemd_Cheatsheet

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-07-25 17:33:48 -0600

Seen: 5,967 times

Last updated: Jul 30 '14