Ask Your Question
0

Google Maps black-screens on Google Chrome

asked 2014-07-24 16:33:28 -0600

JohnSH gravatar image

When I go to Google Maps on Google Chrome (version 36.0.1985.125 from the official Google repos) the window goes black. Google Maps works OK in Firefox.

I can't recall whether this was working previously: have only installed Fedora on this computer relatively recently and can't recall whether I've been on Google Maps on this computer since then. I'd be surprised if I haven't, which suggests it's a new issue. I've previously used Chromium under Arch Linux on the same machine without difficulty.

Graphics card is a Radeon HD 5400/6300 Series, running the open source radeon drivers. Kernel is 3.15.6-200.fc20.x86_64.

edit retag flag offensive close merge delete

Comments

Try updating Flash.

abadrinath gravatar imageabadrinath ( 2014-07-25 03:22:41 -0600 )edit

Thanks for this - unfortunately that doesn't help as Google Maps doesn't use Flash.

JohnSH gravatar imageJohnSH ( 2014-07-26 11:04:33 -0600 )edit

Sorry buggy. My bad, it doesn't use flash. Anyway, this is probably a bug with Chrome. Try chromium.

abadrinath gravatar imageabadrinath ( 2014-07-26 20:14:45 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-08-09 07:30:01 -0600

spot gravatar image

I think this is because you're hitting the WebGL blacklist. In Chrome (or Chromium), go to:

chrome://flags/

Then, enable the "Override software rendering list" option. You may need to restart Chrome/Chromium for it to take effect, but it might fix this for you.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-07-24 16:33:28 -0600

Seen: 1,431 times

Last updated: Aug 09 '14