Ask Your Question
1

Fedora 20 - can't login with other session type

asked 2014-07-17 13:04:55 -0600

trendies1000 gravatar image

updated 2014-07-18 13:39:36 -0600

mether gravatar image

Hi, I have a problem when I try to login with other desktop enviroment when I start my computer, in the "login menu" I write my password and in the "Session type" I choose other desktop enviroment(example cinnamon, gnome, etc) and after I press enter button, I see a black screen for about 1 second telling me several things like "starting fedora with linux..." without tell me if any error, and then again return back to the "login menu", it doesn't matter how many times I try, so I need to choose in the "Session type" the default option(kde) to enter, but I would like to enter the others as well. This problem is recent because at first I have been able to enter in the other desktops but suddenly this error happened.

I have installed several desktops using this: https://ask.fedoraproject.org/en/question/9863/how-to-install-an-entire-desktop/

edit retag flag offensive close merge delete

Comments

1

Could you please create a new user and try logging in with it into other desktop environments to see if it works?

hedayat gravatar imagehedayat ( 2014-07-17 14:32:15 -0600 )edit

I create another user, and try it, but nothing

trendies1000 gravatar imagetrendies1000 ( 2014-07-17 18:25:33 -0600 )edit

I used this command and partially fix my problem system-switch-displaymanager lightdm

trendies1000 gravatar imagetrendies1000 ( 2014-07-17 19:45:08 -0600 )edit
1

So, there might be a bug with your previous display manager (probably KDE's?). You might check to see if there are bug reports about it, or report a new bug.

hedayat gravatar imagehedayat ( 2014-07-18 06:22:18 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-07-18 23:21:19 -0600

abadrinath gravatar image

First, are the display managers installed? Check by using: rpm -qa|grep cinnamon or rpm -qa|grep gnome.

Next, enable them: systemctl enable gdm.service

Last, select them from the list in gdm (not others).

edit flag offensive delete link more

Comments

yep, I checked with rpm -qa|grep cinnamon and appear a list

trendies1000 gravatar imagetrendies1000 ( 2014-07-19 13:24:22 -0600 )edit
1

Then, select it from the list in gdm.

abadrinath gravatar imageabadrinath ( 2014-07-19 20:57:04 -0600 )edit
2

answered 2014-08-29 16:15:33 -0600

deadrat gravatar image

updated 2014-08-29 17:18:48 -0600

I am sorry for typing it in place for answers, but I am unable to add it as comment because of limitations number of characters.

I have the same Issue. I have Fedora 20 with Gnome DE. Gnome was default. Then I installed KDE and then I tried to log in to KDE. The screen goes off, then it says "booting ... Heisenbug" (same way it says when fedora is trying to start), then again goes blank and returns to log in screen.

I installed KDE just today and never was able to login.

I tried to log in to KDE after switching display manager from GDM to KDM. I was able to get to log in screen, when I try to log in, the screen goes blank and comes back to log in screen again.

I checked using the command :

rpm -qa|grep kde

I got the following results:

kde-settings-plasma-20-17.fc20.noarch
kde-style-oxygen-4.11.11-2.fc20.1.x86_64
pykde4-4.13.3-1.fc20.x86_64
kde-plasma-nm-pptp-0.9.3.4-12.fc20.x86_64
kde-baseapps-common-4.13.3-1.fc20.noarch
kdelibs-common-4.13.3-1.fc20.x86_64
heisenbug-backgrounds-kde-20.0.0-1.fc20.noarch
polkit-kde-0.99.1-2.20130311git.fc20.x86_64
kdepim-runtime-4.13.3-1.fc20.x86_64
kde-print-manager-4.13.3-1.fc20.x86_64
kdelibs-4.13.3-1.fc20.x86_64
kde-workspace-libs-4.11.11-2.fc20.1.x86_64
kde-plasma-nm-0.9.3.4-12.fc20.x86_64
libreoffice-kde-4.2.6.2-1.fc20.x86_64
kde-settings-20-17.fc20.noarch
kde-filesystem-4-46.fc20.x86_64

kde-runtime-flags-4.13.3-3.fc20.noarch kdepim-runtime-libs-4.13.3-1.fc20.x86_64 kde-print-manager-libs-4.13.3-1.fc20.x86_64 lockdev-1.0.4-0.11.20111007git.fc20.x86_64 kde-plasma-nm-vpnc-0.9.3.4-12.fc20.x86_64 kdepimlibs-gpgme-4.13.3-1.fc20.x86_64 kde-settings-kdm-20-17.fc20.noarch kdepasswd-4.13.3-1.fc20.x86_64 kde-workspace-4.11.11-2.fc20.1.x86_64 colord-kde-0.3.0-2.fc20.x86_64 kde-runtime-libs-4.13.3-3.fc20.x86_64 kdeplasma-addons-libs-4.13.3-1.fc20.x86_64 kde-plasma-nm-openvpn-0.9.3.4-12.fc20.x86_64 kdegames-minimal-4.13.3-1.fc20.noarch xsettings-kde-0.12.3-7.fc20.x86_64 kde-settings-ksplash-20-17.fc20.noarch kde-settings-pulseaudio-20-17.fc20.noarch kdegraphics-thumbnailers-4.13.3-1.fc20.x86_64 kdelibs-webkit-4.13.3-1.fc20.x86_64 kdepimlibs-akonadi-4.13.3-1.fc20.x86_64 kde-plasma-folderview-4.13.3-1.fc20.x86_64 kde-runtime-drkonqi-4.13.3-3.fc20.x86_64 kdepim-4.13.3-1.fc20.x86_64 kde-plasma-nm-l2tp-0.9.3.4-12.fc20.x86_64 heisenbug-kde-theme-19.90.5-1.fc20.noarch kde-plasma-nm-openconnect-0.9.3.4-12.fc20.x86_64 libkdegames-4.13.3-1.fc20.x86_64 kdeplasma-addons-4.13.3-1.fc20.x86_64 kde-baseapps-4.13.3-1.fc20.x86_64 kde-plasma-nm-openswan-0.9.3.4-12.fc20.x86_64 kdeaccessibility-4.13.3-1.fc20.noarch kdegraphics-strigi-analyzer-4.13.3-1.fc20.x86_64 kdepimlibs-4.13.3-1.fc20.x86_64 kde-runtime-4.13.3-3.fc20.x86_64 kdepim-libs-4.13.3-1.fc20.x86_64

I have no Idea what these means. Then I typed:

systemctl enable gdm.service

Still I am unable to login.

Edit:

I wanted to try a different Desktop, so I installed "Sugar Desktop Environment" and it works fine. but still same problem with KDE.

edit flag offensive delete link more

Comments

You should probably fill a separate question as this question is marked as solved! Anyway, you should try this to change login manager to gdm (-f is required):

systemctl enable -f gdm.service

If it didn't solve the problem, I'd suggest filling a new question.

hedayat gravatar imagehedayat ( 2014-08-30 01:46:18 -0600 )edit

Hi @hedayat , Yeah, I'll do that. Thanks

deadrat gravatar imagedeadrat ( 2014-08-30 09:20:32 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-07-17 13:04:55 -0600

Seen: 2,823 times

Last updated: Aug 29 '14