Ask Your Question
0

ABRT gone crazy - how can I make reset?

asked 2014-07-15 02:16:50 -0600

zoltanh721 gravatar image

Hi

Every time that I would like to help in debugging - ABRT were a big help until now. Looks like ABRT gone mad in reporting module, and libreport & glibc marked by daily as buggy - and doesn't want to send any kind of report even it's completely and properly set, just marking as crash, an counts up as problem happened.

The question is how can I set ABRT back to factory setup, and clean this rubbish content that causing possibly this garbage. How can I find out that what made this madness inside the report module? What should I delete manually? There is no switch as like in yum - the clean all command?

Ty,

Zoltan

edit retag flag offensive close merge delete

Comments

Try reinstalling abrt* using yum reinstall abrt.

abadrinath gravatar imageabadrinath ( 2014-07-15 02:32:34 -0600 )edit

Reinstallling not used at all. I did complete yum autoremove abrt-desktop - witch is an virtual package, and deletes every leaf of packages. I try clean home folders, and then reinstall. I hope nothing left from the garbage. Btw in the removing process I have seen postun faliure - warning: %postun(abrt-gui-libs-2.2.1-2.fc20.x86_64) scriptlet failed, signal 7 Non-fatal POSTUN scriptlet failure in rpm package abrt-gui-libs-2.2.1-2.fc20.x86_64. Should I report this too? Umm, btw this way too many postun faliure is can cause by RPM DB errors locally?

zoltanh721 gravatar imagezoltanh721 ( 2014-07-15 02:51:10 -0600 )edit

sudo systemctl disable abrt?

abadrinath gravatar imageabadrinath ( 2014-07-15 03:03:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2014-07-15 02:31:53 -0600

abadrinath gravatar image

Option 1: Delete the "garbage" (that's what I did)

Just delete using yum erase abrt* or if you want to be on the safe side, sudo systemctl disable abrt.

Option 2: Check out /etc/abrt/abrt.conf

vi /etc/abrt/abrt.conf and edit to your liking. Also, you may want to try ShortenedReporting = yes if in GNOME. Set max size here MaxCrashReportsSize = 1000 #MB.

HTH

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-07-15 02:16:50 -0600

Seen: 381 times

Last updated: Jul 15 '14