Ask Your Question
2

Very slow Fedora 20 after update [closed]

asked 2014-07-12 12:56:41 -0600

Qucco gravatar image

updated 2014-07-12 16:50:17 -0600

mether gravatar image

I update fedora20 after a problem, and now my system is very very slow.
My OS is: Fedora 20 (Heisenbug) (3.14.9-200.fc20.x86_64)
This is result of systemd-analyze plot > plot.svg

Image

Better View

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zoltanh721
close date 2014-07-14 07:04:16.422287

Comments

1

Try this: run systemd-analyze blame > blame.txt edit it to remove anything that takes less than a second and post that as an edit to your question. The plot is pretty, but actually seeing the times is easier for many of us to understand. Between NikTh's suggestion and this, we may be able to assist.

sideburns gravatar imagesideburns ( 2014-07-12 16:52:11 -0600 )edit
Qucco gravatar imageQucco ( 2014-07-12 17:16:52 -0600 )edit

Thanx. I see three obvious candidates: ModemManager.service, lvm2-monitor.service and bluetooth.service. If you're not using a modem or bluetooth and you don't have any lvm volumes, you can use systemctl to mask any or all of them, cutting your boot time by something like 12 seconds.

sideburns gravatar imagesideburns ( 2014-07-12 17:52:32 -0600 )edit

Thanks @sideburns. I masked ModemManager.service and lvm2-monitor.service, but time not changed :| Plot and Blame file

Qucco gravatar imageQucco ( 2014-07-12 18:29:01 -0600 )edit
1

I checked how long accounts-daemon.service takes on my Fedora 19 box and found that it takes 107ms, as compared to 5.906s for you. I haven't been able to find out what it does, so I can't tell you why it's taking so much time at boot for you. However, if it were my system, I'd be researching it.

sideburns gravatar imagesideburns ( 2014-07-12 19:21:23 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2014-07-12 16:02:28 -0600

NickTux gravatar image

updated 2014-07-12 17:35:58 -0600

Use a "trick" . sudo mv /var/log/journal /var/log/journal.org . Reboot the system, re-generate a new plot.svg and see if any differences exist. If the "slow boot problem" being solved from the renaming of journal/ folder, then it's probably this bug.

edit flag offensive delete link more

Comments

Hey Thanks, it's better but yet is slow New plot

Qucco gravatar imageQucco ( 2014-07-12 17:15:58 -0600 )edit

You "earned" 10secs. What was the boot time before this problem ?

NickTux gravatar imageNickTux ( 2014-07-12 17:34:50 -0600 )edit

Yes 10secs!

Boot: It was completely frozen on the fedora boot logo.

Qucco gravatar imageQucco ( 2014-07-12 17:42:23 -0600 )edit

You can try to disable sudo systemctl disable plymouth-quit-wait.service . I've disabled this service completely as it slowed down my F20 too. Also, if the boot freeze, hit the esc key to read any error messages.

NickTux gravatar imageNickTux ( 2014-07-12 17:56:03 -0600 )edit

I removed plymouth package.

Plot and Blame file

How can i arrive to a better time?

Qucco gravatar imageQucco ( 2014-07-12 18:35:10 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-07-12 12:56:41 -0600

Seen: 1,917 times

Last updated: Jul 12 '14